WordPress.org

Ready to get started?Download WordPress

Forums

SI CAPTCHA Anti-Spam
Buddypress error (25 posts)

  1. fk59
    Member
    Posted 3 years ago #

    Hi,

    with buddypress default theme i got this error:

    buddypress/bp-core/bp-core-signup.php(104) : runtime-created function on line 1

    When i disable the plugin, all works correct.

    Any hints?

    Thx, Frank

    http://wordpress.org/extend/plugins/si-captcha-for-wordpress/

  2. Mike Challis
    Member
    Plugin Author

    Posted 3 years ago #

    Sorry you are having trouble.
    Tell me more about your install.
    Buddy press version?
    Any other plugins installed?

    Maybe another plugin is conflicting.
    Look on the Admin - Plugins - menu.
    Temporarily Disable (not uninstall) all your other plugins.
    Does it work now? If yes, Activate the plugins one by one to determine
    which one conflicts. Which plugin was causing it?

  3. djsteve
    Member
    Posted 3 years ago #

    I am getting an error with buddypress too now - not sure what the error is - but when people try to sing up, it just brings back to sign up page. When I deactivate si captcha signups go through no problem.

    buddypres 1.2.6
    si captcha 2.6.3.1
    wpmu - 3.01

    plugins running:
    BP Blog Author Profile Link
    BP Group Documents
    Chat
    Forum Attachments for BuddyPress
    oEmbed for BuddyPress

    I was also running BP-Registration-Options plugin at same time - but even disabling it, the signup function still failed. This only occurred after newest update of SI captcha 2.6.3.1

    I love you plugin, it saves me time and costs spammers time and money, hope we can get a better version soon!

  4. Mike Challis
    Member
    Plugin Author

    Posted 3 years ago #

    djsteve,

    I just setup a test server...
    buddypres 1.2.6
    si captcha 2.6.3.1
    wpmu - 3.01
    Theme: BuddyPress Default 1.2.6

    I installed si-captcha in mu-plugins
    I cannot duplicate the problem.

    Did you install si-captcha in mu-plugins? if not, try that.
    What theme do you have?

    This is how to install SI Captcha globally on WPMU or BuddyPress:
    Step 1: upload the /si-captcha-for-wordpress/ folder and all it's contents to /mu-plugins/

    Step 2: MOVE the si-captcha.php from the /si-captcha-for-wordpress/ folder to the /mu-plugins/ folder.

    Site wide Settings are located in "Super Admin", "SI CAPTCHA Options"

  5. djsteve
    Member
    Posted 3 years ago #

    Thanks for the reply - I will give that method a try. i had it running fine with the previous versions by putting it in a regular "plugins" folder, and clicking to activate sitewide / network activate or whatever they are calling it these days... I will give the mu-plugins folder a whirl and see what happens..

  6. djsteve
    Member
    Posted 3 years ago #

    Ok I just tried that method, and it does not seem to work for my setup for some reason. wp-hashcash is in mu-plugins and shows fine in superadmin. But after putting the si-captcha there, it does not show in the superadmin section, nor show captchas on the signups pages.
    I just woke up and the espresso has not wiped away the haze from my eyes yet. Maybe I will retry this later - and just disable registering on my site - I woke up to more than 1500 new spam signups from last night - grrr.

  7. djsteve
    Member
    Posted 3 years ago #

    Okay, I double checked and it does seem to be enabled now. My ftp hadn't finished the move part yet.

  8. djsteve
    Member
    Posted 3 years ago #

    okay, so using the mu-plugins way of install / run - the captcha appears on the registration page - but it still fails to work. After completing all fields and the captcha - the page just refreshes - no completed sign up page. Same problem as earlier stated.

  9. Mike Challis
    Member
    Plugin Author

    Posted 3 years ago #

    What theme do you have?

  10. djsteve
    Member
    Posted 3 years ago #

    think I found a fix perhaps.. I think during my update I deleted the plugin folder and uploaded the fresh one, activated it, and hoped that all was well. It seemed fine, but I realized I had no signups for three days, which is very unusual.

    After some more poking around, I think that the problem was the lack of a folder being re-created after I deleted the plugin and upadted. Looking at the options I noticed this:
    /wp-content/plugins/si-captcha-for-wordpress/captcha-secureimage/captcha-temp/

    so I created that, and it still didn't work - but then I decided to try it in the mu-plugins folder that I had moved the plugin too - creating a a "capthca-temp" folder there and changin permissions seems to make it work now.

    So now I am going to try to make it work again in the regular plugins folder, and deleting the mu-plugins one.
    I think re-adding that captcha-temp folder has fixed the problem. Hope this helps anyone else who has the same issue. I delete and upgrade through ftp, not through the WP backend.

  11. Mike Challis
    Member
    Plugin Author

    Posted 3 years ago #

    The /captcha-temp/ folder will be made automatically unless there is a permissions problem preventing write access.

    http://codex.wordpress.org/Changing_File_Permissions

  12. firesenshi
    Member
    Posted 3 years ago #

    Hi Mike,
    I also have a concern on SiCaptcha. I put in a new topic. Need your help! Thanks!

  13. moshoodo123
    Member
    Posted 3 years ago #

    hi, i just installed this plugin. i can see the code under all other forms but the code dont appear under comment form and when i try to test the comment, error message appear. please how can i fix this problem

  14. moshoodo123
    Member
    Posted 3 years ago #

    fixed thanks. i put the command in my theme

  15. pyikyaw
    Member
    Posted 3 years ago #

    Hello Mike,

    I have this error ... what should I do?

    ERROR: Could not read CAPTCHA token file.
    There is a problem with the directory /si-captcha-for-wordpress/captcha-secureimage/captcha-temp/.
    Directory Unwritable (fix permissions). Permissions are: 0755 Fixing this may require assigning 0755 permissions or higher (e.g. 0777 on some hosts. Try 0755 first, because 0777 is sometimes too much and will not work.) Fixing the actual problem is recommended, but you can uncheck this setting on the si captcha options page: "Use CAPTCHA without PHP session" and the captcha will work this way just fine (as long as PHP sessions are working).

  16. Mike Challis
    Member
    Plugin Author

    Posted 3 years ago #

    Try the suggestions in the message you posted.

    You can uncheck this setting on the si captcha options page: "Use CAPTCHA without PHP session"
    Do it, does it work now?

  17. pyikyaw
    Member
    Posted 3 years ago #

    but in order to uncheck right? i need to login first and go the option section ... but now i can't even login ... how can make all this work without logging in?

  18. Mike Challis
    Member
    Plugin Author

    Posted 3 years ago #

    If you can't log in because of CAPTCHA error:

    You will have to manually delete the plugin so you can log in again:
    FTP to this folder on your server:
    "/wp-content/plugins"
    and delete the "si-captcha-for-wordpress" folder
    Now you can log in.

    This will disable the plugin and you can log in again.
    You can re-install it, make sure the first thing you do after, is to uncheck "captcha on login form" until you find out if the captcha is working.

  19. pyikyaw
    Member
    Posted 3 years ago #

    thank

    but i still cannot login .. maybe i did it wrong .. i m not sure.. cos i type my company website first then add "/wp-content/plugins" .. however, the page doesn't load .. ... i m sorry to give you much trouble since i m not really good with the com and internet

  20. Mike Challis
    Member
    Plugin Author

    Posted 3 years ago #

    You need to use a FTP program like FileZilla to connect to your web server and delete the "si-captcha-for-wordpress" folder that is located in the "/wp-content/plugins" folder.

  21. pyikyaw
    Member
    Posted 3 years ago #

    i just install the filezilla but they asked me for the server address.. is the server address same with ip address cos i don't know what my server address is and the port no: could you help me out thank mike

  22. Mike Challis
    Member
    Plugin Author

    Posted 3 years ago #

    Usually the server IP address will work for the address. and the default FTP port is 21. If you have any trouble logging in to FTP, please refer to your web host's help documentation.

  23. alias472
    Member
    Posted 3 years ago #

    Hey I've uploaded the plugin but get two errors when I try to register an account: Parse error: syntax error, unexpected T_STRING, expecting ',' or ';' in /home/virtual/site240/fst/var/www/html/wp-content/plugins/buddypress/bp-core/bp-core-signup.php(104) : runtime-created function on line 1

    and

    Warning: call_user_func_array() [function.call-user-func-array]: First argument is expected to be a valid callback, '' was given in /home/virtual/site240/fst/var/www/html/wp-includes/plugin.php on line 395

    here: http://blergz.com/register

  24. scott4design
    Member
    Posted 3 years ago #

    Same problem here as djSteve ... disabled SI captcha and error stopped appearing.

    Will try your fix or go with a different plugin... grrr

    Thanks for posting this

  25. scott4design
    Member
    Posted 3 years ago #

    Okay, well I did not read everything, but DJ Steve's solution worked for me. I changed the permissions on the

    /wp-content/plugins/si-captcha-for-wordpress/captcha-secureimage/captcha-temp/

    folder to 777 and it seems to be working now.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic