WordPress.org

Ready to get started?Download WordPress

Forums

Related Links Blender
[resolved] Plugin show only one related link, not more (9 posts)

  1. CyberPanda
    Member
    Posted 1 year ago #

    Hi.

    I use your plugin on my site and it's doesn't show more than one link. In post editor I can find and insert many posts, but in template is still showing just one. What can I do?

    http://wordpress.org/plugins/related-links-blender/

  2. CyberPanda
    Member
    Posted 1 year ago #

    Oh, no, it's not the problem. The problem is:

    database? When you add some links to post, it works perfectly, whatever how much. But if you want CHANGE this, it doesn't work. It still show which you add as first. I'm trying, but I can't fix it.

    Anybody any idea?

  3. stephenblender
    Member
    Plugin Author

    Posted 11 months ago #

    Sorry tenshinhikaru, I missed the email alert about your post. If you still need help, and after 3 weeks it would not surprise me if you had given up, let me know.

    I'm a little unclear on exactly what is happening on your site. I'll need a link to your website so I can see what is being added.

  4. CyberPanda
    Member
    Posted 11 months ago #

    Oh, it's ok. Thank you for answer :)

    Link's here: new.primacom.cz/?p=53

    It's all about change. Watch my screen-video. I recorded it for you.

    Cache was removed and database checked. In database is still what is showing on page. No link what you change in your admin is change in database. Try this, you'll see. Can you fix this?

    On my blog I also tried it: link .

    And here it doesn't work too.

  5. stephenblender
    Member
    Plugin Author

    Posted 11 months ago #

    Loved the video! So great to see someone using it how I had planned it. Made things very clear. (You are the second person with the giant thumbs, must fix that.)

    That is interesting. Cache would have been my first guess, but it sounds like that is out.

    In the second link you sent, to your blog, when I visited there were two related links at the bottom. Is the problem of a link not being added consistent or just sometimes? Or in the three days since you posted here did it resolve itself?

    I looked at the generated code and it looks correct, except for there only being one link in the primacom.

    I have some ideas, let me fool around a little.

    ps. I was expecting WordPress to send me alerts when people post here, but I have not received them for yours. Sorry. I'll check in more the next few days.

  6. CyberPanda
    Member
    Posted 11 months ago #

    :) Your plugin can be really great - i'm glad you created it!

    I found this in my database... In wp_postmeta are meta_key "related_links_blender_links" and "related_links_blender_links_cached".

    In related_links_blender_links is everything ok. Here is all new changes what I made. It's showing correctly below Post Editor. But in related_links_blender_links_cached is just my first choice what's showing on my page. Here's no change - just like I showed in screen-video.

    On my blog (second link) are two links, 'cause it was my "first choice". That means: I added two links and then I clicked on "publicate" or "upgrade" post. After I click on Publicate (or Upgrade), it's saving in database and can't be changed anymore (in related_links_blender_links_cached).
    ---

    And about the giant thumbs: it's in administration of your plugin (Related Links Blender Settings). If you change value of "Image thumb width(or height), if included" from 150px to something else, changed are thumbs below post editor, not on page.

    I hope it'll helpfull!

    (If you want, you can email me your email adress (if you don't want post your address in public here) and I'll send you an alert instead WordPress :D (medard@primacom.cz))

  7. stephenblender
    Member
    Plugin Author

    Posted 11 months ago #

    My email is stephen@blender.ca, but I like having this conversation here for reference and transparency . I have subscribed to this thread so should get better alerts.

    I have a theory. You mentioned that the 'cache was removed' by which I am guessing you mean you turned off something like WP SUPER CACHE? I am asking because with that plugin turned on I am able to re-create what your video showed, with it off my plugin works for me as expected for me. Let me know if you are using a server side cache plugin.

    The functionality of my plugin is that related_links_blender_links_cached is written whenever add or delete in the control pane are pressed. It is not required to 'update' the post. I might change this in the future as it is not intuitive...I was just enthusiastic about ajax.

    I have a build of the plugin I can send you that has more verbose logging to the web browser console. Willing to give it a try? You would need to be able and willing to ftp updated plugin files to your web server and watch the console for logged messages. Specifically it logs the value stored in related_links_blender_links_cached so you can compare that to what is in the control pane and what shows up in the post.

    Let me know! You can email me your email and I will send you the plugin files.

    Thanks for your help,
    Stephen

  8. CyberPanda
    Member
    Posted 10 months ago #

    Hi!

    Sorry for late answer. WP Super Cache isn't conflicted with your plugin. Everyhting was just about ajax as you said :) Just do not click on Update and it's ok.

    Oh, wait, you fix it? Now it's working everytime! No matter if I'm clicking on Update/Publicate or not. Cool. And thumbnails are ok too.

    Thank you!

    (If you want, I can help you with anything else like a tester.)

  9. stephenblender
    Member
    Plugin Author

    Posted 10 months ago #

    Thanks! I will let you know if I need any testing. Just by using the plugin and giving feedback you are already helping!

    ps. another way you can help is with feature requests or by giving a review or star rating.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic