WordPress.org

Ready to get started?Download WordPress

Forums

ShortCodes UI
[resolved] Shortcode not inserting parameter value (2 posts)

  1. mendocinotim
    Member
    Posted 2 years ago #

    Please watch this short movie to see what I'm doing and what's not working.
    http://jing.videvent.com/2012-04-23_14-10-17.mp4

    SUMMERY:
    I have the following code that I want Shortcode UI to insert, with a single parameter that would be passed ..

    <!-- START EMBED CODE -->
    
    <script type="text/javascript" src="http://sspd.videvent.com/m/embed.js"></script>
    
    <div id="gallery-7">
    
    </div>
    
    <script type="text/javascript">
    	SlideShowPro({
    		attributes: {
    			id: "gallery-7",
    			width: 625,
    			height: 475
    		},
    		mobile: {
    			auto: false,
    			poster: "vignette"
    		},
    		params: {
    			bgcolor: "#000000",
    			allowfullscreen: true
    		},
    		flashvars: {
    			xmlFilePath: "http://sspd.videvent.com/images.php?gallery=7",
    			paramXMLPath: "http://sspd.videvent.com/m/params/salt.xml",
    			startup: "Open Gallery",
    			videoAutoStart: "Off",
    			navAppearance: "Visible on Rollover",
    			feedbackPreloaderAppearance: "Spinner",
    			transitionLength: 1
    		}
    	});
    </script>
    
    <!-- END EMBED CODE -->

    In this code shown above I replaced the value of the xmlFilePath parameter with a Shortcode Attribute, like this..

    <!-- START EMBED CODE -->
    
    <script type="text/javascript" src="http://sspd.videvent.com/m/embed.js"></script>
    
    <div id="gallery-7">
    
    </div>
    
    <script type="text/javascript">
    	SlideShowPro({
    		attributes: {
    			id: "gallery-7",
    			width: 625,
    			height: 475
    		},
    		mobile: {
    			auto: false,
    			poster: "vignette"
    		},
    		params: {
    			bgcolor: "#000000",
    			allowfullscreen: true
    		},
    		flashvars: {
    			xmlFilePath: "{XMLpath}",
    			paramXMLPath: "http://sspd.videvent.com/m/params/salt.xml",
    			startup: "Open Gallery",
    			videoAutoStart: "Off",
    			navAppearance: "Visible on Rollover",
    			feedbackPreloaderAppearance: "Spinner",
    			transitionLength: 1
    		}
    	});
    </script>
    
    <!-- END EMBED CODE -->

    Then when I use Shortcode UI, where it asks me for the XMLpath (the way it should), it for some reason does not insert the value I ask for - leaving the xmlFilePath value out, as seen when I view the resulting WP page's html source.

    I am using the Simple One Tag ShortCode method.

    Please advise on this, if you don't mind.

    And thank you.

    http://wordpress.org/extend/plugins/shortcodes-ui/

  2. Bainternet
    Member
    Plugin Author

    Posted 2 years ago #

    Hi,

    I saw your video and it does look like you are doing everything right accept you are using capital letters in the attribute name which sadly will never work, so try changing XMLpath to xmlpath in the attribute you create and in the template.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic