WordPress.org

Ready to get started?Download WordPress

Forums

Plugin - shopping cart not working **error** (6 posts)

  1. ggnarso
    Member
    Posted 3 years ago #

    So I just updated my wordpress version to 3.0 and also updated the shopping cart plug in as well, but for some reason the plug in is not working.

    When I click on the link it says this

    Fatal error: Cannot use string offset as an array in /home/content/43/5469643/html/acctrix/wp-content/plugins/eshop/eshop-add-cart.php on line 140

    I also checked my shopping cart plug in as well to find out the problem, but when I go to the eshop-add-cart.php on my edit page, it's inactivated. How can I fix it?

    I need to get this problem solved asap. thanks!

    click here for the web link! thank you!

  2. elfin
    Moderator
    Posted 3 years ago #

    I also checked my shopping cart plug in as well to find out the problem, but when I go to the eshop-add-cart.php on my edit page, it's inactivated.

    can you explain what you mean by inactivated? do you when you try to activate it? or when you upgrade it?

    if you've added a product to the shopping cart page, try removing it and adding it to another page and see if that fixes it.

  3. ggnarso
    Member
    Posted 3 years ago #

    There were no problems before I upgraded both WordPress and eshop, but after wards, the eshop plugin inactivated itself. I didn't add new products or change text/pics.

  4. elfin
    Moderator
    Posted 3 years ago #

    then I don't know what has caused the error - sorry.

  5. ggnarso
    Member
    Posted 3 years ago #

    Can you please tell me what this means though?
    here is the web link for the error message on the shopping cart.

    I'm not exactly sure what it means by error on line 140. I checked, the coding, but it still didn't make any sense.

  6. elfin
    Moderator
    Posted 3 years ago #

    the script is trying to look for an option/price of a product, and there isn't one.

    However the error shouldn't be happening at all, which is why I'm at a loss. The script shouldn't get to that part unless there is a product to look for.

Topic Closed

This topic has been closed to new replies.

About this Topic