WordPress.org

Ready to get started?Download WordPress

Forums

Shopp Wholesale
Plugin could not be activated because it triggered a fatal error. (40 posts)

  1. mrmarky1982
    Member
    Posted 3 years ago #

    Hi I'm running Shopp version 1.017 and I wanted to try out your plugin as I was after a solution to be able to set wholesale/base prices for products.

    I've tried to activate the plugin on 3.1 standalone and 3.1 with multisite enabled and I get the error mentioned in the topic title.

    my browser bar suggests the error as follows http://mysite.com/wp-admin/network/plugins.php?error=true&plugin=shopp-wholesale%2Fshopp-wholesale.php&_error_nonce=598b3a6e1a

    Hopefully you are able to help resolve this?

    http://wordpress.org/extend/plugins/shopp-wholesale/

  2. Dalton
    Member
    Posted 3 years ago #

    I'm getting the same fatal error on activation with WP 3.1 standalone. I will try to troubleshoot tonight and let you know if I come up with anything.

  3. hjrascoe
    Member
    Posted 3 years ago #

    Yes, I received the same exact error message when attempting to activate via WP 3.1. Any success fixing this error @Dalton?

  4. Dalton
    Member
    Posted 3 years ago #

    I posted something to the thread on the Shopp forum, no word back from Tyson yet.

    The error on initialization is

    PHP Fatal error: Undefined class constant 'CUSTOMER_QUEUE_TABLE' in /home/user/public_html/beta/cms/wp-content/plugins/shopp-wholesale/classes/Database.php on line 20

  5. hjrascoe
    Member
    Posted 3 years ago #

    Ok, thanks for the update. hopefully will hear something from tyson soon. I'll follow the post on the shop website in the mean time. Thanks again for your help.

  6. anemo
    Member
    Posted 3 years ago #

    I have the same setup as mrmarky1982 and also need this plugin. Actually, I need it A LOT! :)

  7. Dalton
    Member
    Posted 3 years ago #

    Tyson posted a new download on Monday. Does it work for you?

    https://forums.shopplugin.net/topic/shopp-wholesale-management-plugin/page/2

  8. anemo
    Member
    Posted 3 years ago #

    @Dalton: I wasn't able to load the page (your link). I wasn't even able to reach http://www.shopplugin.net. Does it work for you?

  9. Dalton
    Member
    Posted 3 years ago #

    I was able to access that page 10 minutes ago, it seems to be down now. Try again in a little while, it should come back up. I haven't downloaded the updated code yet, I was going to do it this weekend.

  10. anemo
    Member
    Posted 3 years ago #

    Now I have downloaded the files from the forum thread mentioned above but I still get a fatal error when trying to activate the plugin :(

    BTW, I'm using Shopp 1.1.7.

  11. Dalton
    Member
    Posted 3 years ago #

    Just got a response from Tyson on the Shopp forum - just delete line 20 from the /classes/Database.php file and the plugin will activate. I can't believe I didn't at least try that.

    You'll also want to comment out line 38 of /admin/AdminMenus.php to get rid of the menu item for customer accounts. That functionality has been moved to another plugin.

    Seems to work now... good luck!

    Dalton

  12. anemo
    Member
    Posted 3 years ago #

    Hey, cool!

    Now it activates and the wholesale option is available on the product pages. I have to test it some more though but it looks really promising!

    Thanks for the help!

  13. hjrascoe
    Member
    Posted 3 years ago #

    @anemo. What versions of Shopp / WordPress are you using?

  14. anemo
    Member
    Posted 3 years ago #

    @hjrascoe: Hi! I'm using WP 3.1 and Shopp 1.1.7.

  15. anemo
    Member
    Posted 3 years ago #

    I have been trying out the plugin a bit now but I can't get the pricing to work properly. The wholesale price is shown even if the Default Customer Type is set to Retail and not logged in.

    Maybe I'm doing something wrong?

  16. Dalton
    Member
    Posted 3 years ago #

    Yeah, you need to set the default customer type to wholesale, add a new user of that type, then log in as that user. Then you should see the wholesale pricing.

  17. anemo
    Member
    Posted 3 years ago #

    Ah, that works but I still see the wholesale price when that user is logged out. Shouldn't the Default Customer Type be set to Retail for the retail prices to show when a wholesale user isn't logged in?

    However, changing Default Customer Type to Retail doesn't affect the price. It's still wholesale pricing that is shown.

  18. sherodesigns
    Member
    Posted 2 years ago #

    Is anyone having any luck with this plugin? I see it is in BETA testing still. When will there be a full release?

  19. rayatrogue
    Member
    Posted 2 years ago #

    Any updates for this?

  20. stowepro
    Member
    Posted 2 years ago #

    I just installed removed the two lines of code listed by what Dalton Rooney said to do.

    I have a product set to show a different prices if someone is a subscriber but for some reason it will not show. As a test I even made it if they were a wholesaler instead of subscriber but nothing shows on the site other then the price. I wanted to make it so that when someone logs in to the site that the prices will be different. As in member pricing versus non member pricing. I believe this plugin will do it however it doesn't seem to be working.

    Any ideas. I am using the latest wordpress and shopp pluggin if that helps.

    Dalton Rooney, are you able to point me in the right direction?

    Thanks

  21. stowepro
    Member
    Posted 2 years ago #

    I got it to work. Awesome. This is a great addition. I followed the same work configuration from this link. http://staging.edieandbup.com.au/

    Create an account, sign in and look at all the setting to make sure your match just like this one and it will work like a charm.

  22. stowepro
    Member
    Posted 2 years ago #

    Crazy situation. I just noticed that the general wordpress settings disappears when I activate the plugin. Strange. any ideas.

  23. paulruescher
    Member
    Posted 2 years ago #

    stowepro,

    open up classes/admin/AdminMenus.php and replace the following starting on line 28:

    /**
    	 * Install our admin menu.
    	 */
    	function initAdminMenu() {
    
    		//add our submenu
    		$hook_main = $this->addMenu('settings');
    		$this->addMenu('presentation', $hook_main);
    		$this->addMenu('account-settings', $hook_main);
    
    		//COMMENT THIS OUT $accounts_hook = $this->addMenu('accounts', ShoppWholesale::SHOPP_MENU_ROOT, 'Customer Account Requests', 'Account Requests');
    		$this->addMenu('account-review', $accounts_hook);
    
    		//reorder menus
    		$this->sendToBottom('Settings');
    
    		//COMMENT THIS OUT $this->__TEMP__dodge_up_adminMenus();
    
    	}
  24. stowepro
    Member
    Posted 2 years ago #

    @ paylruescher,

    Wow, that did the trick. Thank you for the code change. That worked perfectly.

    Again thank you.

  25. paulruescher
    Member
    Posted 2 years ago #

    No sweat, let me know if you run into any other problems. I check into here periodically.

  26. stowepro
    Member
    Posted 2 years ago #

    @ Paulruescher,

    A new problem just came up that wasn't a problem before. The insert image now causes an error and won't let the images upload. If I disable the wholesale plugin, it the image upload will work again.

    Any ideas? Just a note, it was working fine before the suggested code change for the adminmenus.php.

    Again thanks.

  27. paulruescher
    Member
    Posted 2 years ago #

    For products, or just for pages/posts? Kind of a quick fix, but if you uncomment

    $this->__TEMP__dodge_up_adminMenus();

    then it should allow you to upload your images. When you need the Settings tab again, just recomment that line out. There's a note in the code that this function needs to be fixed, so it's definitely a little buggy here.

  28. stowepro
    Member
    Posted 2 years ago #

    Actually the issue only happens when placing new products within shipp plugin.

    I tried um commenting the code though the issue still seems to present itself. The only thing that seems to correct the issue is if I disable the wholesale plugin.

    You're right, it is a little buggy but I do appreciate your help.

    thanks again.

  29. paulruescher
    Member
    Posted 2 years ago #

    did you try disabling flash image upload?

  30. stowepro
    Member
    Posted 2 years ago #

    Bingo. That fixed it.

    Thanks paulruescher. You are the best.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic