WordPress.org

Ready to get started?Download WordPress

Forums

Shashin
Invalid data property __get for fancyboxCyclic (11 posts)

  1. Patrick Nommensen
    Member
    Posted 2 years ago #

    I just updated to the latest version and something is not right.

    Shashin Error:

    Invalid data property __get for fancyboxCyclic

    If the plugin developer could take a look I would appreciate it, thanks!

    http://wordpress.org/extend/plugins/shashin/

  2. waggles1955
    Member
    Posted 2 years ago #

    I got the same error message when I installed the Shahin automatic update and my website went haywire.

    I fixed the problem by re-uploading the previous version of Shashin 3.09 (I think) Firstly I DEACTIVATED the newer version of Shashin, then I uploaded the previous version v3.09 using Filezilla Client. While uploading, it asked me to "over ride" ALL files when asked to do so, to which I said "Yes" and once it finished, it was automatically enabled in the plugins folder of wp.

    Problem FIXED!!!! ... I now have my website back again YESSSS!!!!.

    I won't be updating that program anytime soon. It wipes all your photos and leaves your website in a shambles, with the error message you mentioned above.

    All the best in now fixing your website.
    Pete.

  3. Patrick Nommensen
    Member
    Posted 2 years ago #

    Yeah I did the same thing, I just wanted to be the first to post and make the plugin developer aware.

  4. klevur
    Member
    Posted 2 years ago #

    I am having the same issue. I have tried installing each upgrade of the Plugin Shashin. Each upgrade breaks things and I get the error message:

    Shashin Error:
    Invalid data property __get for fancyboxCyclic

    Any help on this would be great.

  5. Sergey L
    Member
    Posted 2 years ago #

    Try to deactivate and re-activate Shashin plugin.

  6. Mike Toppa
    Member
    Plugin Author

    Posted 2 years ago #

    I just learned that when the automatic plugin update shows you a message saying its deactivating and reactivating the plugin, it's not really doing it:

    http://core.trac.wordpress.org/ticket/17833

    As Sergey said, you will need to deactivate and reactivate Shashin in your plugin menu after updating.

    I just uploaded version 3.1.3 which address several Fancybox issues.

    Also, so you know, I had to switch to Fancybox in order to keep Shashin in the wordpress.org repository, as Highslide is not compatible with the repository's GPL licensing requirements. It was a lot of work switching to Fancybox, and it wasn't something I was originally planning to do.

    waggles, what do you mean it "wipes out all your photos"? That definitely should not happen. If I can help you debug, let me know.

  7. Sergey L
    Member
    Posted 2 years ago #

    Now automatic update to version 3.1.3 do deactivation and re-activation by itself. But error message appear againg: "Invalid data property __get for fancyboxInterval".
    Manual re-activation help to fix it.

  8. waggles1955
    Member
    Posted 2 years ago #

    @ Mike ... On my front page of the website, I lost all my photos that were on a revolving slideshow. It was replaced with a large orange box with the error message in it. Hence I had NO photos from the 6 odd photos that useually rotate non stop.

    I couldn't access any of my pages ie, NO drop down menues when I ran my mouse over the tool bar at the top, ... I freaked out because I had just run a paid promotion on Groupon and hundreds of people were trying to access my website while all this was happening to it.

    Once I re-installed the old verion back onto it, it worked fine, hence I'm now not going to touch it as the Groupon ad is still running till Sat. It was out for probably half an hour or so.

    You need to make sure (or whoever it is that makes the updates), that they work first on a few other computers before putting them up for us "novices" to install, like a beta version or something. Had what I tried not worked, I would have been one upset guy by now. But thankfully, all went well for me in the end.

    It also doesn't help to read that other people, everytime they do an update on this program, they have problems ... WTF?.

    I'm new to WP as I'm a photographer not a web designer (could be my problem right there hey?), but I get by ok cause I've been working on computers for well over 12 years now and can work out most problems ok. But it should be simpler for guys (novices) like me to install updates, thats all I'm saying, instead you find out that your whole wesite crashes around you when you do an update.

    Sorry for the rant, but it could have been serious for me, had it not worked in the end, but its all good now! LOL :)

  9. Mike Toppa
    Member
    Plugin Author

    Posted 2 years ago #

    What I didn't realize is that WordPress' auto-update function no longer runs the plugin's activation hook (it used to), even though the message says it is activating the plugin - http://core.trac.wordpress.org/ticket/17833

    The auto-update behavior is something that is not possible to test without an actual upload of a new version to the repository. That was the main source of people's troubles. The quirks with Fancybox were due to me having to rush to replace Highslide, as its not compatible with the licensing requirements of the wordpress.org repository (it has a Creative Commons license, not GPL; my bad for not being aware the licenses are not compatible).

    If you are happy with Highslide, and you don't need multi-site support, you'll be fine staying on 3.0 for now. The main changes in 3.1 are multi-site support and the switch to Fancybox.

  10. gaston909
    Member
    Posted 2 years ago #

    Hmmm,

    I updated the latest version but it just replaced all my photos with tags...

    I tried to deactivate the plugin with no joy, now I just get a 500
    error.

    http://www.pauljgaston.com/wp-admin/plugins.php?action=deactivate&plugin=shashin%2Fstart.php&plugin_status=all&paged=1&s&_wpnonce=e15b4d3027

    Server error
    The website encountered an error while retrieving http://www.pauljgaston.com/wp-admin/plugins.php?action=deactivate&plugin=shashin%2Fstart.php&plugin_status=all&paged=1&s&_wpnonce=e15b4d3027. It may be down for maintenance or configured incorrectly.
    Here are some suggestions:
    Reload this web page later.
    HTTP Error 500 (Internal Server Error): An unexpected condition was encountered while the server was attempting to fulfil the request.

    Not sure where to go from here... All my other plugins deactivate without any problems...

    Just shasin thats upset...

    Any ideas? :)

  11. gaston909
    Member
    Posted 2 years ago #

    [Mon Apr 16 15:50:23 2012] [error] [client 192.166.203.10] PHP Fatal error: Class 'ToppaAutoLoaderWp' not found in /home/sites/pauljgaston.com/public_html/wp-content/plugins/shashin/start.php on line 72, referer: http://www.pauljgaston.com/wp-admin/plugins.php

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags