WordPress.org

Ready to get started?Download WordPress

Forums

Sharedaddy
Post Only setting not working (7 posts)

  1. Chuck Reynolds
    Member
    Posted 3 years ago #

    So in sharedaddy settings, I have the dropbox set to 'Post Only' and the buttons still display on pages and posts... If I set it to 'Index only' then it works okay and displays on the index/home correctly but I only want the buttons to display on posts on the single template and not pages.

  2. John Godley
    Member
    Plugin Author

    Posted 3 years ago #

    That's working correctly then - posts refers to posts and pages. It's a bit unwieldy to keep referring to posts and pages. You can disable it on pages using the checkbox at the bottom of the edit post page (!)

  3. Chuck Reynolds
    Member
    Posted 3 years ago #

    Uh.... although I can MAYBE agree with you on the 'posts' and 'pages' are the same thing.. thing... The plugin makes no sense. Why say "index PAGES only" then? why not "index posts only"? To me it seems you're contradicting yourself.

    Why have one place for settings but make somebody go to every single page on their site to disable it when you have the setting set to "posts only"? WordPress still separates them and calls the individual post types different things (pages and posts). Why have a control panel if I have to go to every single page to modify something? I could see IF I had "posts and pages" selected THEN it would show up as an option in pages to disable if I didn't want it on some pages.

    Right now it seems broken and I'm not a fan - I don't think that makes the most sense for the majority of users. just sayin.

  4. John Godley
    Member
    Plugin Author

    Posted 3 years ago #

    I meant that in terms of the plugin, posts and pages are treated the same. It says 'index pages only' because it is an index page not an index post.

    The plugin is working exactly as it should. Most people have had no problem with the terms used, but admittedly they could be clearer.

    There is an option on every post and page to disable the plugin.

  5. Dene
    Member
    Posted 3 years ago #

    Hi John

    Thanks for the Sharedaddy plugin. It looks very nice.

    Like Chuck, I only want the share options to show on posts not posts and pages. It just doesn't make sense on pages like 'FAQ'.

    Within posts, I only want to display the Share on certain categories.

    I have a large number of posts and pages. Most don't need the Share Options.

    It would be great for me if there was an option to turn the display 'OFF' by default then I could enable it for certain posts. Is that possible?

    Thanks.

    Dene

  6. John Godley
    Member
    Plugin Author

    Posted 3 years ago #

    Currently no, although it may be included in a future release

  7. Raquel Wilson
    Member
    Posted 3 years ago #

    I have been unable to get the plugin to fully work. I am using the Thesis framework and found a work around for Thesis here. However, now, even though I have the option to have Sharing appear on "Posts, pages, and index pages", the buttons are not appearing on posts or pages. They do show on the homepage (index) page.

    Any ideas on how to fix this?

    Here is plugin working on the index page:
    http://www.odettemanon.com/

    And here is the same post on it's individual page where the plugin is not working:
    http://www.odettemanon.com/2011/03/some-catchy-headline-goes-here/

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags