WordPress.org

Ready to get started?Download WordPress

Forums

Share and Follow
[resolved] Icons do not display after fresh install (44 posts)

  1. SecGen
    Member
    Posted 3 years ago #

    Hi,

    I'm currently using AddtoAny, but some of the features of Share and Follow are appealing and I am considering a switch.

    Unfortunately after I install Share and Follow, the share icons do not show up, and the tab on the right side of the screen does not look properly formatted.

    You can mouse over where the icons are meant to be, and see the hyperlinks - but no icons themselves.

    Any ideas?

    http://wordpress.org/extend/plugins/share-and-follow/

  2. solidspark
    Member
    Posted 3 years ago #

    I've recently installed this plugin, and I've had the same problem as you have. I've discovered why.

    This plugin is user tracking. I checked stylesheet.css in /wp-content/plugins/share-and-follow/ and found that the icons are being pulled from a third party website:

    .size16 .twitter{background: transparent url(http://www.city-zen-clothing.com/wp-content/plugins/share-and-follow/default/16/twitter.png) no-repeat}

    Changing the URL from the stylesheet to relative paths fixes the issue.

  3. SecGen
    Member
    Posted 3 years ago #

    Hi solidpark,

    Thanks for the info. Indeed hotlinking isn't good practice, and I hope this can be taken out of the plugin. That said, it doesn't appear to be the hotlinking that's causing the problem on my end. When I check the source, all of the Share and Follow icons are set to blank.png

    http://www.domain.com/wp-content/plugins/share-and-follow/images/blank.png

    So naturally nothing is displayed. But why would it be doing this?

  4. Lynn
    Member
    Posted 3 years ago #

    I was missing the icons, too.

    WordPress 3.0.1
    Sahre and Follow Version 1.21.6
    Theme: The PaperCore by Pexeto

    I had installed the plugin using the Add Plugins auto installation and then had upgraded from WP 3.0 to 3.0.1 some time after that.

    I deleted the Plugin from within WordPress. Then instead of using the auto-install, I downloaded Share and Follow, unzipped it, and uploaded the share-and-follow folder to wp-content/plugins using an FTP program. The icons appeared after that. And all of my Share and Follow settings were intact, too.

    Wat was truly odd before I tried the fix described above was that when I copied the URL to any of the icons and pasted that into a browser I got a File Not Found error even though my FTP program and server Control Panel's File Manager indicated that the icon files were indeed there.

    Anyway, given my configuration as listed above, deleting the plugin from within WordPress and then uploading it via FTP solved the missing icons problem.

  5. SecGen
    Member
    Posted 3 years ago #

    Hi artsmo,

    Thanks for the tip, unfortunately this didn't fix it for me.

    Any comment from the dev?

  6. Lynn
    Member
    Posted 3 years ago #

    I haven't received or seen any news on this. But it is still working for me. I wonder if there are permissions issues. . .? Most of my stuff in that plugin directory is set to 755 or 754.

  7. andykillen
    Member
    Plugin Author

    Posted 3 years ago #

    Hey All

    Please check the latest version of the plugin and see if that fixes it for you, I have removed substantial amounts of CSS and also changed the way the icons are generated. Hopefully that should fix any compaibility issues that you are facing.

    version 1.50 should be the one for you.

    Please let me know if you still have issues
    All the best
    Andy

  8. SecGen
    Member
    Posted 3 years ago #

    Hi andy,

    Thanks for the update! Making progress... the icons are now appearing! Only one small thing is still missing, the Follow tab on the right side doesn't display correctly. The text is horizontal, whereas it should be vertical (although the icon is appearing now).

    Any ideas?

  9. andykillen
    Member
    Plugin Author

    Posted 3 years ago #

    Hey SecGen,

    What I think will be the quickest solution for you is to. . . .

    1. Open your website with an FTP client (example written using Filezilla)
    2. change to the /wp-content/plugins/share-and-follow/css/ directory
    3. highlight stylesheet.css and the right click and select File Permissions
    4. Change the file permissions for that file to 644

    do the same for print.css

    if that does not resolve it, try 777 (total hammer to crack a nut approach)

    all the best
    Andy

  10. SecGen
    Member
    Posted 3 years ago #

    Hi Andy,

    Thanks for the tip. 644 didn't work, but 777 did! So much for the nut.

    I have a few questions about Share and Follow:

    1) Is it possible to set the order in which the share links (icons) are displayed?
    2) Is it possible to have an 'other' link/icon that shows all of the other share options whose icons are not shown on the page itself?
    3) is there a way to prevent the share links from appearing on any given page/post? Add2Any allows you to put an html comment like <!--nosharesave--> to stop the links from being displayed.

    Thanks again, I look forward to trying out the plugin. I've been considering replacing Add2Any, but want to make sure I have all the features I need.

  11. SecGen
    Member
    Posted 3 years ago #

    Hi Andy,

    A bit off-topic for this thread, but clicking on the Bookmark icon to save a page/post as a bookmark currently tries to bookmark as follows in Firefox:

    javascript:window.bookMark('http://blog.com/post', 'Post+Name',%20BrowserDetect.browser);

    ie. The bookmark contains the full javascript, which means that clicking on that bookmark doesn't work.

  12. SecGen
    Member
    Posted 3 years ago #

    Just updated to the latest version and had to 777 those two css files again. Is there a reason I'm having to do this, and can it be fixed on the plugin side?

    I'm assuming some other users are also having this issue.

  13. andykillen
    Member
    Plugin Author

    Posted 3 years ago #

    Hey SecGen

    I can't say why some servers do not allow or setup automatically this file. It should install perfectly with the default settings of 644 and be working. I can only guess there is a different config on your server

    and for the bookmark stuff, I'll take another look at that one. thanks for the pointer

    regards
    Andy

  14. andykillen
    Member
    Plugin Author

    Posted 3 years ago #

    Hey SecGen again....

    I've looked into the coding of the stuff and it's correct, I think it's something to do with the release of firefox last week. I think that update screwed things up. I'm gonna contact Mozilla to have a chat and work it out with them

    regards
    Andy

  15. SecGen
    Member
    Posted 3 years ago #

    Thanks for the bookmark fix... bookmarking works now, only one small thing remains and that is that the post name in the bookmark has + instead of spaces.

    eg. My+post+name

    Any thoughts on my queries below?

    1) Is it possible to set the order in which the share links (icons) are displayed?
    2) Is it possible to have an 'other' link/icon that shows all of the other share options whose icons are not shown on the page itself?
    3) is there a way to prevent the share links from appearing on any given page/post? Add2Any allows you to put an html comment like <!--nosharesave--> to stop the links from being displayed.

    Thanks again.

  16. skabrat
    Member
    Posted 3 years ago #

    My issue is that the widget sidebar no longer displays the follow RSS feed icon and text, even though that is checked in the widget sidebar options setting. it worked fine before the last couple of revs.

    ?

  17. andykillen
    Member
    Plugin Author

    Posted 3 years ago #

    Hey Skabrat,

    I've just tested that item with version 1.50.5, can you tell me what version you are using?

    regards
    andy

  18. andykillen
    Member
    Plugin Author

    Posted 3 years ago #

    Hey SecGen

    The + thing will have to wait on the makers of firefox, mozilla.

    other answers
    1) working on it at the moment, will be there very soon
    2) not yet as you are the first to have asked for it
    3) yes you can exclude sharing or following on specific pages or posts by entering their ID into the exclude boxes on the admin screen for share and follow.

    Andy

  19. SecGen
    Member
    Posted 3 years ago #

    Hi Andy,

    I find that having to enter the IDs of specific posts to exclude is slightly clunky, and creates extra work.. particularly when this is something you do regularly (eg. excluding share links in micro-blog posts).

    Do you think it might be possible to either add a checkbox on the Add Post page that turns it on/off (on by default) - or - as Add2Any does it, have a specific comment tag that can be added that prevents the share links from showing on that particular post.

    Many thanks again, Share and Follow is a good plugin and I look forward to its upcoming developments.

  20. skabrat
    Member
    Posted 3 years ago #

    I am using 1.50.5. Just upgraded to 1.51, but I am still seeing the same problem. I open the follow widget, I make sure the RSS box is checked (along with twitter, facebook, and stumble). The other follow items are listed on my home page, but RSS is missing from the widget display. This worked perfectly a week or so ago. I haven't changed any of the settings for this plugin.

  21. andykillen
    Member
    Plugin Author

    Posted 3 years ago #

    Hey Skabrat,

    I've setup the same thing as you on numerous servers now since seeing your post. No problems anywhere to be seen.

    Can you try re-adding the widget to your sidebar and starting again. This might sort you out.

    regards
    Andy

  22. andykillen
    Member
    Plugin Author

    Posted 3 years ago #

    Hey Skabrat,

    I'm not sure but I think I might know what the problem is. I think it's a theme CSS issue with your theme and the new way the plugin works.

    The quick fix is to change from "Single Images" to "Sprites" in the widget for showing the icons.

    Not sure why yet but on some themes the single images do not always show.
    regards
    Andy

  23. Clopin
    Member
    Posted 3 years ago #

    Hi all,

    Installed the plugin, everything works fine (very nice plugin btw, thx a lot)n version 1.52.3.
    Only thing I'm missing is icons in the 'follow' section. The share ones are showing, but as you can see on http://blog.fort9.be/ the ones in follow aren't there.
    I tried the manual reinstall artsmo suggested and the plugin is set to sprites like the dev said but unfortunately that didn't help :(

  24. andykillen
    Member
    Plugin Author

    Posted 3 years ago #

    for your site this will do the job

    #follow.right ul li {margin:0 3px}

    regards
    Andy

  25. Clopin
    Member
    Posted 3 years ago #

    Magic, thx. I really should get my css up to speed :)

  26. bondjack
    Member
    Posted 3 years ago #

    Hi Andy,

    Great plugin, I got the share icons working. But I'm totaly stuck with the side bar follow tab, I can't get it on screen :S. I use wp as a cms tool not als blog for this page. I didn't setup a sidebar for widgets is that the problem? - http://www.varenopdekaag.nl/home/. I hope you can help me out.

    Cheers,

    Jacob

  27. andykillen
    Member
    Plugin Author

    Posted 3 years ago #

    Bondjack

    can you open your theme's footer.php and make sure that wp_footer is being used... just before the closing body tag i.e.

    <?php wp_footer(); ?>
    </body>
    </html>
  28. bondjack
    Member
    Posted 3 years ago #

    :S that easy..... I feel a bit stupit ;) thx a lot, works well now :)

  29. andykillen
    Member
    Plugin Author

    Posted 3 years ago #

    bondjack,

    cool. glad it's good for you. btw: I am based in Amsterdam or Apeldoorn depending on the status of my girlfriends pregnancy/my office, feel free to contact me off list if you need any WP things doing that are above the norm. Either though share-and-follow.com or phat-reaction.com

    regards
    Andy

  30. Mythnick
    Member
    Posted 3 years ago #

    icons not working in the follow widget

    pls help !!!!!!!!!
    http://www.hdmusicvideo.ro

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic