WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Shadowbox JS] Stopped Working Since Upgrade to 3.03 (66 posts)

  1. daganloy@gmail.com
    Member
    Posted 4 years ago #

    Hi Sivel,

    I tried deactivating all the plugins and still no luck. It doesn't make sense the Modal would affect the entire plugin to stop working? What I don't get is why there would be a conflict now with the theme, when there was no conflict before the upgrade. I had set Modal to true on the older version and it worked perfectly fine.

    Thanks again!

    UPDATE: it seems as though if there are ANY settings changed, the Shadowbox plugin won't work.. THe only way I can get it to work right now is by resetting it to default. Any changes to the javascript settings(visual settings such as overlay color work fine) will cause the entire script to not work..

  2. Matt Martz
    Member
    Posted 4 years ago #

    daganloy@gmail.com:

    As I keep telling everyone, I cannot troubleshoot a problem when there is no problem. If a problem presents itself after making a change, then you need to leave that change and thus leave the plugin broken. If you revert the settings and I cannot see the problem then I cannot troubleshoot said problem.

  3. daganloy@gmail.com
    Member
    Posted 4 years ago #

    Sivel: Sorry about that i was just playing with it and I forgot to leave it broken for you to see. I have changed it to jQuery and Modal to true. My theme uses jQuery so I assume that would work fine. The older version of Shadowbox I had it on jQuery as well and it worked fine.

  4. Matt Martz
    Member
    Posted 4 years ago #

    daganloy@gmail.com:

    Ok, the problem seems to be with how this plugin stores it's cached copy of shadowbox.js.

    In your case the cached file has been stored at:

    http://www.trumoments.ca/wp-content/uploads/shadowbox-js/aef9fa4ac9bd82bcd0d46928b145c6b0.js

    However it appears as though this file can not be read properly by the web server, and is returning a 404. Please check to make sure this file exists and that the file system permissions permit it to be read by everyone.

    That file would exist in wp-content/uploads/shadowbox-js/aef9fa4ac9bd82bcd0d46928b145c6b0.js of your WordPress install.

    Alternatively you could also just try deleting that file if you are unable to get it to stop returning a 404 file not found, this plugin would then fall back to building shadowbox.js on the fly and delivering it through admin-ajax.php

  5. daganloy@gmail.com
    Member
    Posted 4 years ago #

    Hi Sivel,

    Thanks a lot for you time. But it seems that I don't have that file? I have a bunch of files in there, but not that one. I went and checked all the permissions and it's set for anyone. I went ahead and deleted all the files in that upload/shadowbox-js/ folder.. then i disabled the plugin, then enabled it again to see if i could make it fresh.. The problem still exists.

    I am going to try a completely fresh install to see how it goes.

    *UPDATE:
    Okay after all that deleting and fresh installing, the plugin seems to not even work at all, even when i reset it to default from the shadowbox settings menu.. What could possibly be the problem?

  6. Matt Martz
    Member
    Posted 4 years ago #

    Configure the plugin the way that you want it, then delete the directory wp-content/uploads/shadowbox-js and test again, after deleting the directory to not make any modifications to the configuration.

    On another note, I checked your site and it is working now.

    The problem seems to be that the file is getting created but not with the correct file permissions causing the check for file_exists to pass but not actually work as expected.

    The current file that is created is: http://www.trumoments.ca/wp-content/uploads/shadowbox-js/38d81d42ef30ac1f746f9b2e7a646b40.js

    If you want to try something else edit wp-content/plugins/shadowbox-js/inc/frontend.php and change the only reference to file_exists to is_readable. Making that change would likely solve this problem all together, and is going to likely been in the next release of the plugin.

  7. daganloy@gmail.com
    Member
    Posted 4 years ago #

    It seems to be working for you? Can you confirm this again? Because I just tried ALL of your steps and its still not working. It just jumps to the movie file.. i clear my cache and refresh the page everytime I check and still nothing.

    Sivel, perhaps if you have skype or msn, I could provide you server access so you can get a better controlled look?

  8. davro10
    Member
    Posted 4 years ago #

    Hi Sivel. I have tried everything to get Shadow box working, reset, turned other plugins off but still have the same problem. When I tried to delete for a clean install I get the following message.

    Warning: in_array() [function.in-array]: Wrong datatype for second argument in /home/davrodi/public_html/wp-content/plugins/shadowbox-js/inc/admin.php on line 514

    Warning: in_array() [function.in-array]: Wrong datatype for second argument in /home/davrodi/public_html/wp-content/plugins/shadowbox-js/inc/admin.php on line 514

    Warning: Invalid argument supplied for foreach() in /home/davrodi/public_html/wp-content/plugins/shadowbox-js/inc/admin.php on line 520

    Warning: Cannot modify header information - headers already sent by (output started at /home/davrodi/public_html/wp-content/plugins/shadowbox-js/inc/admin.php:514) in /home/davrodi/public_html/wp-includes/pluggable.php on line 868

    Thanks David

  9. svenzn
    Member
    Posted 4 years ago #

    I'm about to literally pull my own hair out over here. I tried out the plugin on a wordpress-installation (along with many others), finally deciding this was the one to use. Adn it worked perfectly, no problems at all.

    So I head on over to my other wordpress installation, which more or less had the same plugins and they were both running WordPress 2.8.7. I install the plugin on this other wordpress installation, and, of course, it doesn't work. The links just open the videofile as a new page instead of using the Shadowbox. I think to myself, well maybe I have to update my wordpress, and get the latest, 2.9.2. Still the same problem. I deactivate every other plugin. Still same problem. I switch theme to the default. Still the same problem. I try earlier versions of the plugin, still the same problem. I just don't know what I'm missing here, so a little help would be much appreciated.

    You can check a temp-page with example of links, not working, on this link: http://bdforum.se/vc/temp

    It's password-proteced since it has nothing to do with the rest of the site, Password: shadowbox

    Hope someone can lend a helping hand, because the plugin was perfect when I had it working on the other installation.

  10. Matt Martz
    Member
    Posted 4 years ago #

    davro10: That means that you have unchecked every one of the players listed at Settings->Shadowbox JS. Doing so will not let shadowbox work at all.

  11. Matt Martz
    Member
    Posted 4 years ago #

    @svenzn:

    I have taken a look at your site and firebug is returning an error:

    invalid object initializer
    http://bdforum.se/vc/temp
    Line 241

    That line number refers to:
    <a href="http://www.youtube.com/v/uz1hUj7buYc" rel="shadowbox[post-2175];player=swf;width=650;height=385;">Youtube</a>

    I tested this exact line on my install and it works without any problem which leads me to believe it may be a theme/plugin conflict. Disable all plugins and test again, if it works then one of your plugins is conflicting. If this doesn't solve it, switch to the default theme and test it, if it works then your theme is causing the conflict.

  12. svenzn
    Member
    Posted 4 years ago #

    I just tried disabling all the plugins, but that didn't help, so I tried using the default theme while all the plugins were disabled as well, but that didn't work either. Gonna try and disable the adds on the site, see if that helps because I really can't see what's causing the problem, since it works fine on a separate wordpress-installation on the same server...

    Edit 1: Scratch that last part about adds, because I just realized there aren't any on te test-page :P

    Edit 2: Okey, so I just ruled out the theme as the perpetrator because I installed the theme on the other wordpress-site and it works just as well as before on that one. *sigh*

  13. nimo32
    Member
    Posted 4 years ago #

    Sivel: Posted this message on your site, but after careful reading I saw that I have to post my problems here.... my apologies.

    Great plug-in… but the newest version 3.0.3.2 will not work (with images) on my site. I have to use an older version like 3.0.0.3. (I use the Mimbo theme). When an image is clicked, the image is shown on a new page in the same window.... so no shadowbox.

    http://www.niekfotografie.nl/2010/01/basilica-di-san-marco/

    I'm getting this error:

    Error: Shadowbox is not defined
    Source File: http://www.niekfotografie.nl/2010/01/basilica-di-san-marco/
    Line: 295

    Update: it seems to be working now after changing file permissions in wp-content/uploads/shadowbox-js

  14. davro10
    Member
    Posted 4 years ago #

    Hi Sivel I have checked all the boxes and tried every option after reading this thread. I have even deactivated other plug-ins which I think is what you meant but still the same problem. It seems flv files download and mov files open full screen. I've tried both flv and mov incase that was the problem.

    I have installed this before without a hitch and it work brilliantly until the update.

    Thanks david

  15. svenzn
    Member
    Posted 4 years ago #

    Got it working now after uninstalling the plugin from the other wordpress-site and the current, as well as disabling all plugins and reverting to Default theme and then installing the plugin so that it was the only plugin installed, followed by activating the other things one by one. And no, can't say I see the logic in why it works now and not before, but it does, so I'm happy, I guess. :P Thanks for a great plugin!

  16. nimo32
    Member
    Posted 4 years ago #

    Update: it seems to be working now after changing file permissions in wp-content/uploads/shadowbox-js

    But when new files are created under the wp-content/uploads/shadowbox-js dir, then those new files do not have the right permissions. I have to manually change the permissions (with for example Filezilla). New files are created with permission 660.

    Any idea?

    PS. Not all files are cached under wp-content/uploads/shadowbox-js? I can only see a couple, not for all of my images. I made the change you suggested earlier:

    If you want to try something else edit wp-content/plugins/shadowbox-js/inc/frontend.php and change the only reference to file_exists to is_readable.

    This does not solve my problem.

  17. Matt Martz
    Member
    Posted 4 years ago #

    @nimo32:

    The only thing that is cached is the actual javascript file (shadowbox.js). The reason you see multiple files is that a file is generated each time you save your settings to reflect the settings you have saved.

    As for the file being created with the wrong permissions, that is something I am adding to the next release. I didn't anticipate the poor hosting configurations that people are using.

  18. nimo32
    Member
    Posted 4 years ago #

    Sivel,

    Thanks for your response.

    I didn't anticipate the poor hosting configurations that people are using.

    So my hosting provider is to blame that a new file is created with 660 permission? I did not know that.

  19. nimo32
    Member
    Posted 4 years ago #

    The only thing that is cached is the actual javascript file (shadowbox.js). The reason you see multiple files is that a file is generated each time you save your settings to reflect the settings you have saved.

    When I view the source of a page, there is a link to the oldest created cached file.... why not a link to the newest created file?

  20. Matt Martz
    Member
    Posted 4 years ago #

    @nimo32:

    For the permissions thing, your hosting provider has specified what the default file permissions will be for files created by PHP, and apparently these file permissions do not allow it to be read by the web server.

    As for the question about caching, it is not done based on date, it is done based on configuration. So if the original cache file, was for default settings, you then changed some settings, and then switched back to default, the cache would not be recreated it would just use the cache file that was originally created.

  21. Daz Lunn
    Member
    Posted 4 years ago #

    Hi Sivel,

    I didn't clock that you would need to interrogate my site's settings, apologies - my bad.

    The reason I reverted was because I was away for a few days and didn't want to leave it in a state where I couldn't tinker around with it.

    Do you want me to go back and update now and see what happens? Looks like there has been a flurry of activity since my original post. Let me know - and also let me know if there is something I need to modify after the update... Cheers.

  22. Matt Martz
    Member
    Posted 4 years ago #

    @Daz Lunn: Have you updated to the most recent version yet? If not do so. After updating visit Settings->Shadowbox JS and reset the settings to defaults and reconfigure as needed. If it does not work after doing so, please let me know here. I will try and take a look as quickly as possible. I monitor the RSS feed for this forum, and google reader is a little slow to pick it up, but I should see it relatively soon.

  23. Daz Lunn
    Member
    Posted 4 years ago #

    @Sivel: Update completed, looks good to go now, appears to work on all media. Many thanks.

  24. pfista
    Member
    Posted 3 years ago #

    I updated to 3.0.3.2 and when vimeo shadowboxes come up it says "this video is unavailable"

    http://asdffilms.com/blog/?p=299

  25. savavoom
    Member
    Posted 3 years ago #

    Hello all,

    I, like most people in here, have upgraded to the latest version of shadow box - 3.0.3.2

    And now it's stopped working.

    I've tried disabling stuff, resetting the plugin to defaults etc.

    The site I had it on is:

    http://www.discopixels.com

    And I also had a page where I used javascript to call shadowbox to make a video pop up in shadowbox, here:

    https://www.discopixels.com/canvas-builder

    Now none of it works but it was working perfectly before the upgrade.

    Any help would be gr8.

    Thanks

  26. Matt Martz
    Member
    Posted 3 years ago #

    @savavoom:

    Please try the development version:

    http://downloads.wordpress.org/plugin/shadowbox-js.zip

    Steps to upgrade manually:

    1) Deactivate the Shadowbox JS plugin
    2) Delete the previous shadowbox-js folder from the /wp-content/plugins/ directory
    3) Upload the new shadowbox-js folder to the /wp-content/plugins/ directory
    4) Activate the Shadowbox JS plugin

  27. savavoom
    Member
    Posted 3 years ago #

    Still doesn't work :-(

    This is the site:

    http://www.discopixels.com

    I've installed the development version as you suggested.

    Thanks
    Robbie

  28. Matt Martz
    Member
    Posted 3 years ago #

    @savavoom I have just updated the development version to add a new option.

    Upgrade following the steps described previously. Once you have upgraded visit Settings->Shadowbox JS and change "Use Cached shadowbox.js" to false and click "Save Changes".

    This should solve your problems.

  29. gabaozin
    Member
    Posted 3 years ago #

    Dear Sivel,
    Thanks in advance for the great plugin and for the help you have been providing people here in this post.

    I'm having the same problem as the others. The videos will only open on fullscreen, at youtube's website.

    I have already read everything, tried on a fresh instalation of wordpress with the default theme and with no plugins, and it worked.
    Tried on my theme, removing all other plugins, and it didn't work.

    So I believe the problem is in my theme.
    Do you have an idea on where these theme incompatibilities are often found?

    I believe the interaction between your plugin and Youtube/Vimeo simplegallery is perfect for what I was planning to do..
    Would love to be able to make it work!

    If, and when, you have the time, I wouldn't bother if you could have a look at: http://www.gabriel-leveau.com/videos and see if you find out what could be the problem. And I'll continue the work from my side.

    Thanks in advance!

  30. Matt Martz
    Member
    Posted 3 years ago #

    @gabaozin,

    Your problem seems to be a larger issue with your site. Open your site and then view source, scroll all of the way to the bottom. Your content is being cut off. There are missing items that should be output by shadowbox. For one thing, I see no </body> or </html> tags. You need to check your themes footer.php and fix it. On top of that make sure you have <?php wp_footer(); ?> directlry before the </body> tag as well.

    Once you fix your theme, it should start working.

Topic Closed

This topic has been closed to new replies.

About this Topic