WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Shadowbox JS] Stopped Working Since Upgrade to 3.03 (66 posts)

  1. Daz Lunn
    Member
    Posted 4 years ago #

    I'm actually on WordPress 2.9.2

    I upgraded this morning to the latest version of the plugin. Since then Shadowbox JS does not work at all.

    So far I've tried:

    • Deactivating and reactivating
    • Uninstall/reinstall
    • Tried each different JS library - none have any effect
    • Deleted all cached pages and the browser cache - no change
    • Enabled/disabled smart loading, neither makes a difference.

    What should I do? Go back to the previous version?
    Previous version worked perfectly, I should've stuck with it..
    --------
    Also, I have disabled the img title push plugin as it prevents the img displaying if there is a title already there which is different to the title in the anchor. I don't really need this functionality anyway, I'm just letting you know that there's some kind of conflict there.
    --------
    url: http://tgcgs.com

    http://wordpress.org/extend/plugins/shadowbox-js/

  2. kjetilgf
    Member
    Posted 4 years ago #

    Hi
    I have a very similar problem, and regrettably it doesn't help reverting to v3003: FLV videos starts downloading - while mov files open, just in a new page.
    I've tried all mentioned above (apart from deleting cache pages, since I don't use any cache plugin) and not changed anything else.
    NOW: Could anyone else try either
    the video page - or
    the pano page (this requires Quicktime)
    I wonder if this is some weird cache problem, also because...
    @Daz Lunn: It seems that the shadowbox works fine on your site, both here and here.
    Eventually: Other ideas?
    Thanks,
    Kjetil
    PS Running WP291 - and I use this rel tag:
    rel="shadowbox;height=336;width=448"

  3. Matt Martz
    Member
    Posted 4 years ago #

    @Daz Lunn: You cannot possibly expect me to troubleshoot the problems if you revert to a previous version which it appears that you have. Upgrade to 3.0.3 and leave it long enough for me to see it.

    @kjetilgf: It seems as though you have some broken configuration options in flashParams and flashVars. Try setting "Reset to Defaults" to true and clicking "Save Changes". After this you will need to re-enable the flash player.

  4. jcruzrivera
    Member
    Posted 4 years ago #

    Hi:

    I upgraded to 3.0.3 and have lost the shadowbox effect - my videos now only open in full browser windows. I tried to revert but had the same problem. I have upgraded again. Could you please help with the troubleshooting? Thanks. The url is sinapsispr.com/videos

  5. Matt Martz
    Member
    Posted 4 years ago #

    @jcruzrivera: You seem to be experiencing the same problem as kjetilgf. Please try setting "Reset to Defaults" to true and clicking "Save Changes". After this you will need to re-enable the flash player if it was previously enabled.

  6. jcruzrivera
    Member
    Posted 4 years ago #

    Thanks for the quick response. I tried your suggestion but had no luck. I also noticed that my sidebar conditional logic broke (I was using the widget logic plugin). I uninstalled both shadowbox js and the widget logic plugin, reinstalled shadowbox and still have videos playing in full screen (and I can't seem to get the widget logic plugin to work - not even on its own..)

  7. klagreca
    Member
    Posted 4 years ago #

    +1 for Shadowbox not working since upgrade to 3.03.
    Did all of the above steps, plus tried resetting the configuration to default. No luck.

  8. Matt Martz
    Member
    Posted 4 years ago #

    @jcruzrivera: if resetting didn't work something is messing with the output that this plugin is generating. I am seeing:

    flashParams: <p>{bgcolor:"#000000", allowFullScreen:true}</p>
    ,
    flashVars: <p>{}</p>

    In the view source of your page. Basically looks like something is adding <p></p> tags around those values and then they are being escaped.

    It should instead look like:

    flashParams: {bgcolor:"#000000", allowFullScreen:true},
    flashVars: {},

    I am still testing multiple configurations to determine if it is a problem with this plugin or if something else is interfering.

  9. Matt Martz
    Member
    Posted 4 years ago #

    @jcruzrivera: do you mind disabling all of your plugins and testing again? All except this plugin. Also if that doesn't solve it could you keep them disabled and switch to the default theme? You don't need to keep it that way, just long enough for you to test.

    Also do you mind giving me a list of the plugins you are running?

  10. jcruzrivera
    Member
    Posted 4 years ago #

    Hi - I disabled all plugins, reset to defaults and still no luck. The plugins I had active were:

    BM Custom Login
    cforms
    Exclude Pages from Navigation
    Google Analyticator
    Google Map Shortcode
    Iframe Embedder
    Latest Posts from Category
    Simple Google Map
    Subcategory Loader
    Tiny MCEAdvanced
    Widget Logic
    WordPress Database Backup

  11. jcruzrivera
    Member
    Posted 4 years ago #

    I tired it with the default template and it worked.

  12. klagreca
    Member
    Posted 4 years ago #

    I disabled all plugins, and it still didn't work.
    Using Thematic as my theme.,WP 2.9.2
    Also, switched to "default" theme. No change.

  13. Matt Martz
    Member
    Posted 4 years ago #

    @klagreca: please provide a link to a page/post on your site where it is not working.

  14. Matt Martz
    Member
    Posted 4 years ago #

    @jcruzrivera: What is the theme you are using? Is it a free or premium theme? Just asking so that I could test with it if possible.

  15. fk59
    Member
    Posted 4 years ago #

    here it also dont works since 3.03

    I reset to defaults without success.

    http://www.schachplatz.de

    greetz
    Frank

  16. fk59
    Member
    Posted 4 years ago #

    here it also dont works since 3.03

    I reset to defaults without success.

    http://www.schachplatz.de

    greetz
    Frank

  17. fotopolis
    Member
    Posted 4 years ago #

    Hello.
    Here is not working at all since updated to 3.03 version.
    Example: http://www.experienciadigital.es/2010/03/kaspersky-pure-el-nuevo-antivirus-para-usuarios-dometicos-mas-completo-de-kaspersky/

    I have done all have been said in this thread.
    I have a premium theme.

    In my web lines are these too:

    flashParams: <p>{bgcolor:"#000000", allowFullScreen:true}</p>
    ,
    		flashVars: <p>{}</p>

    Any help?

    Thanks a lot!

  18. Matt Martz
    Member
    Posted 4 years ago #

    I am not entirely sure what is happening here, and I have not been able to duplicate it, however I just released an update to the plugin that may help, after the update shows up please install and give it a shot. Let me know if it helps.

  19. fk59
    Member
    Posted 4 years ago #

    Hi sivel,

    great, now it works again correct.

    But - i still get no close-button :-(

    Can you tell me whats wrong here?

    Thx, Frank

  20. fotopolis
    Member
    Posted 4 years ago #

    Hello.
    Thanks a lot!
    For me, now it's working ok.

    Thanks a lot!

  21. Matt Martz
    Member
    Posted 4 years ago #

    For anyone that cares, I was using wp_htmledit_pre to filter those 2 lines, and apparently there are some themes and such which hook into that filter which caused <p> tags to be added and then escaped.

  22. Matt Martz
    Member
    Posted 4 years ago #

    @fk59: from looking at the behavior on your site I am inclined to believe it is a conflict with another plugin.

  23. kjetilgf
    Member
    Posted 4 years ago #

    Brilliant Sivel!
    With your 3.0.3.1 update it works perfectly also in WP 2.9.1. Great!
    Resetting to defaults didn't work with v 3.0.3. For some reason, instead of the default settings in the "Flash Params" and "Flash Vars" fields (under Advanced configuration), some <p> tags where added - just as you said half an hour ago. In other words, it was possible to see it quite easily - if one only knew what to look for:
    Flash params:
    <p>{bgcolor:"#000000", allowFullScreen:true}</p>
    instead of
    {bgcolor:"#000000", allowFullScreen:true}
    (should be the default setting) - and
    Flash Vars:
    <p>{}</p>
    instead of just
    {}
    And deleting the <p> tags didn't help - they just showed up again. (They still do, but they don't cause any problems.)
    Just to let you know how it looked here.
    A big thanks again,
    Kjetil
    PS Using the Atahualpa theme and WP 2.9.1
    PPS No plugin conflicts neither, though I need about 40. Complex site...
    PPS Just discovered that you have to remove the <p> tags and Save to make it work. Even though they reappear after saving, removing them first makes a big difference. At least here.

  24. daganloy@gmail.com
    Member
    Posted 4 years ago #

    Hi Sivel, I have been having a lot of problems Since this upgrade, kind of sucks, but I can't seem to figure out what's wrong. I even upgraded it to the recent one you have. this is my link:

    <div class="button_for_films"><a rel="shadowbox;width=800;height=340;title=;" href="/films_files/2009/1_2009_Wedding_Demo_Reel.mov">Play Demo Reel</a></div>

    and it was working absolutely fine, so I'm sure nothings wrong with that code..

    Another concern for me is the "Modal" option.. I'd like to have it to true, since some of my users accidentally click the background lots.. and it was set to true, until after the upgrade, and when I set it to true it didn't work either..

    any information will help a lot, thanks!

  25. daganloy@gmail.com
    Member
    Posted 4 years ago #

    Hi Sivel,

    Okay I did a little self-troubleshooting. Now I reset all the functions to default using the reseter on the settings page. It started working again, GREAT. BUT, what I would still like is for the Modal to be turned on so that if the visitor clicks overlay, it doesn't go anything. But the problem is, when I turn Model to "true" it's like it disables Shadowbox completely! Then when I try and change it back to false, it brought me back into the same problem before, where no matter what settings I choose it will just not work at all. If i reset it to default, its working again. Modal somehow screws it up, and also I seem to be having this problem when I set the javascript library from "None" to "jQuery".

    Oh and here is the link to the page I am using it on. It's obviously the Play button.

    http://www.trumoments.ca/films/2010/5-2010-wedding-demo-reel/

    UPDATE:
    After another bit of troubleshooting, I tried tweaking the admin.php file to set the default values to what I want, then I "reset" to these settings to that to see if I can get that to work temporarily. After I change the Modal to true, and reset it to this "Default" it still does not work. Then I reverted the admin.php default settings back, reset it to that and it works again, but still the problem where Modal or Javascript libraries won't work if settings are changed...

    Hope that helps!

  26. davro10
    Member
    Posted 4 years ago #

    Hi

    I'm having a lot of problems since updating to 3.0.3.2. When you click on the play button the videos just start to download or open full screen.
    http://davro-digital.com/wp/?p=846

    I'm using WP 2.9 .2

    I have check all the settings and read through this thread but no go so far.

    Thanks for any help

  27. Matt Martz
    Member
    Posted 4 years ago #

    daganloy@gmail.com: I just tested the modal settings as of a few minutes ago. When set to 'false' in the admin, clicking outside of the overlay will close it, when set to 'true' clicking outside does not cause it to close. So it appears to work as documented. Currently on your site I see that it is set to 'false'. To modify this setting in the admin go to Settings->Shadowbox JS, click the "Show Advanced Configuration" button, scroll down to Modal and set it to 'true' and then click 'Save Changes'.

    If that fails to work for you then it is a conflict with either your theme or another plugin.

  28. Matt Martz
    Member
    Posted 4 years ago #

    @davro10:

    I cannot see that the plugin is even activated. I don't see the url to shadowbox.css in the head, I don't see any of the configuration in the footer, and I don't even see the word "shadowbox" in the source of the page at all.

  29. davro10
    Member
    Posted 4 years ago #

    Thanks for the reply Sivel. Both Shadowbox JS and Shadowbox JS Use Title from Image are activated, the problems are the same as the comments above. If the code is missing could it be the theme and what would need to be added if it is..?

    This page the video opens full screen, other start to download the videos
    http://davro-digital.com/wp/?p=3287

    Thanks again

  30. daganloy@gmail.com
    Member
    Posted 4 years ago #

    Hi Sivel,

    Yes I know where to change the Modal settings, otherwise I wouldn't know what Modal does. I don't see how Modal can be in conflict with other plugins or themes? As Shadowbox older version didn't have any of these conflicts with my theme, and I haven't touched anything else since the upgrade. I have now turned it on to True, and now it doesn't even work. I will try disabling other plugins though.

    THanks

Topic Closed

This topic has been closed to new replies.

About this Topic