WordPress.org

Ready to get started?Download WordPress

Forums

Shadowbox JS
Shadowbox not working (15 posts)

  1. Theography
    Member
    Posted 2 years ago #

    Shadowbox not working....I have all the latest versions.
    please take a look:
    http://www.theophotography.com/

    http://wordpress.org/extend/plugins/shadowbox-js/

  2. Matt Martz
    Member
    Plugin Author

    Posted 2 years ago #

    It would appear as though your footer.php or whatever file has </body> in it is missing the call to <?php wp_footer(); ?> directly before the </body>. It should look like:

    <?php wp_footer(); ?>
    </body>
  3. Theography
    Member
    Posted 2 years ago #

    Heres a snapshot of my footer.php
    Shadowbox still doesn't work.

    [Code moderated as per the Forum Rules. The maximum number of lines of code that you can post in these forums is ten lines. Please use the pastebin]

  4. Matt Martz
    Member
    Plugin Author

    Posted 2 years ago #

    Ok, the code that needs to show up in the footer is now there. But you have another problem, that can be fixed form the Shadowbox JS settings page.

    Go to Settings->Shadowbox JS, then set Use "Cached shadowbox.js" to "false" and click "Save Changes".

    I imagine this should fix the issue.

  5. publicradio
    Member
    Posted 2 years ago #

    I can't get Shadowbox JS to work on [gallery] shortcode, either. It works everywhere else. If I insert a gallery, and then insert another image outside of the gallery that links to a larger image, that will work, and now the [gallery] will work. Without that, though, [gallery] shortcode will not trigger shadowbox. Any ideas?

  6. mediaflashix
    Member
    Posted 2 years ago #

    i cant get shadowbox JS working. Install direct through WP Plugin-Install, <?php wp_footer(); ?> where it should be. Cache deactivated. Any ideas?
    watch: http://www.monoscopio.eu

  7. Matt Martz
    Member
    Plugin Author

    Posted 2 years ago #

    @mediaflashix: VIa FTP or whatever means you use, go to wp-content/uploads and delete the directory called shadowbox-js. Once done, visit Settings->Shadowbox JS and follow the steps to download and install the Shadowbox Source files.

  8. publicradio
    Member
    Posted 2 years ago #

    There's an option to only load shadowbox when it sees rel="shadowbox" on the page. If I uncheck this, my galleries work with shadowbox.

  9. mediaflashix
    Member
    Posted 2 years ago #

    thx matt for response. Followed your instructions but same result. Any further advices?

  10. Matt Martz
    Member
    Plugin Author

    Posted 2 years ago #

    @mediaflashix: In that case, the issue must be that the files are being created with the wrong permissions and that the user the web server runs as cannot read them. You can usually update permissions through an FTP application. You would want to update the perms on wp-content/uploads/shadowbox-js and all files and directories inside of that

  11. theconstantrambler
    Member
    Posted 1 year ago #

    Hello, I've installed this plugin today with the basic 2012 theme and it doesn't shadowbox any of my pictures. I also had jetpack carousel installed and it wouldn't do it either. I deactivated the jetpack carousel feature as I prefer to use shadowbox and it won't turn on. I bet I'm missing something basic can someone help? http://www.theconstantrambler.com

  12. frigovelha
    Member
    Posted 1 year ago #

    I`ve noticed, while I was trying to put the plugin working on my website, that the initial configuration of all float numbers (overlay opacity, resize duration, etc.) are using comma (,). When I changed them all into period (.) the plugin started working nicely.

  13. Fauxlimey
    Member
    Posted 1 year ago #

    I'm having trouble with Shadowbox when used with a gallery on a legacy post. If I add a gallery to a new post, Shadowbox works fine. The perms on files in the new gallery are set at 644. I tried changing them to 644 on the old post uploads, but it made no difference. Clicking on a gallery image just loads that image on a new page. Any more suggestions?

  14. tonysmithdesign
    Member
    Posted 1 year ago #

    I'm not sure if this will help but I spent 2 days working on my issue which fell under the category "Shadowbox not working".

    I manage multiple sites and have been using Shadowbox JS on several of them. I installed the plugin on all of them using the WordPress Admin > Plugin panel. Until recently this was fine but the plugin failed to work on the latest site I'm in the process of building. To be more specific, the plugin partially worked but failed to open images in a light box. The plugin did generate the required (rel="shadowbox...") attribute for all links with images but for some reason images would only open in a page and not in a light box.

    My solution was to go to the author site (http://www.shadowbox-js.com/download.html) and download the source files manually. I selected all the player options, downloaded the source files, then uploaded only the shadowbox.js file to my server. I chose the location wp-content/plugins/shadowbox-js/js/shadowbox.js for my purposes but this shouldn't matter. Keep in mind, this is in addition to retaining the active version of the plugin already installed in the Admin panel.

    I then updated my header.php file to include a static reference to the shadowbox.js file AND included the Shadowbox.init(); call like below. I tried commenting them out individually and it turned out that both needed to be included for it to work. In addition, this update had to be included below the default <link> and <script> tags that the plugin generates.

    <link rel="stylesheet" type="text/css" href="http://oxygenfactor.com/site/wp-content/uploads/shadowbox-js/src/shadowbox.css">
    <script type="text/javascript" src="http://yoursite.com/wp-content/plugins/shadowbox-js/js/shadowbox.js"></script>
    <script type="text/javascript">
    Shadowbox.init();
    </script>

    So to summarize...

    1. Have Shadowbox JS plugin already installed.
    2. Go to http://www.shadowbox-js.com/download.html to download source files
    3. Upload only the shadowbox.js file to your server
    4. Place the included code below the default <link> and <script> tags that the plugin generates.

    Not sure if this helps everyone but it worked for me.

  15. sitkol
    Member
    Posted 1 year ago #

    Shadowbox will not work for me at all, I have latest versions of it and WP. When I am logged into WP and open my site on a seperate page Shaddowbox works fine, then I log out of WP and open up my site again and all images just open in a seperate plain page. Please help. http://capturingadventure.com/storm-chasing-2012/

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic