WordPress.org

Ready to get started?Download WordPress

Forums

Shadowbox JS
Shadowbox appear BELOW the headerpicture ... ???. (12 posts)

  1. Jan Huniche
    Member
    Posted 2 years ago #

    I have WP 3.4 and have installed the shadowbox JS´╗┐ plugin 3.0.3.10.2.
    When i click on the pictures... It opens in shadowbox as expected... BUT Appears BELOW the headerpicture... ???.

    The shadowbox should appear above the headerpicture... But instead the shadowbox is partly hidden by the headerpicture ... !!!.

    Any solutions ... ???.

    :-). Jan

    http://wordpress.org/extend/plugins/shadowbox-js/

  2. Rosie-L
    Member
    Posted 2 years ago #

    Hi Jan.

    I'm curious as to exactly what you mean -- what result you are getting.

    Is it possible for you to provide a URL?

    - Rosie

  3. Jan Huniche
    Member
    Posted 2 years ago #

    Try these test links :

    http://www.janhuniche.dk/?page_id=82
    http://www.janhuniche.dk/?page_id=80

    And click on the links and open the galleries and scroll.

    :-) Jan

  4. Rosie-L
    Member
    Posted 2 years ago #

    Oh yes, that's weird. I hope the shadowbox guy can solve it for you. Unfortunately he doesn't seem to drop by that often.

    - Rosie

  5. Matt Martz
    Member
    Plugin Author

    Posted 2 years ago #

    The problem is that you seem to have a bogus z-index for your #branding element of 9999. This is causing the header to appear on top of everything else.

    /* =Header
    ----------------------------------------------- */
    
    #branding {
    	border-top: 2px solid #bbb;
    	padding-bottom: 10px;
    	position: relative;
    	z-index: 9999;
    }
  6. Jan Huniche
    Member
    Posted 2 years ago #

    Ehhh... ???.
    What is it supposed to be... And how and where do i fix it ... ???.

  7. faxesystem
    Member
    Posted 2 years ago #

    I have the same problem. I already removed he z-index from the style.css but shadowbox is still underneath the header. http://teitmaschine.de/products-page/musik/

    Thanks in advance

  8. Matt Martz
    Member
    Plugin Author

    Posted 2 years ago #

    @faxesystem: You do not appear to have removed the z-index, it is till showing in the style.css, but I am realizing that it is actually twentyeleven that is setting the crazy z-index.

    There are a few other options, edit wp-content/plugins/shadowbox-js/css/extras.css or the CSS of your theme and add the following:

    #sb-container {
            z-index: 10000;
    }

    I may just add this into the next release as well.

  9. Jan Huniche
    Member
    Posted 2 years ago #

    Im a novice in WP and dont know how to change the settings/parameter in the CSS file.

    Can somebody please tell me step by step "How to" ???.

  10. kc6715
    Member
    Posted 2 years ago #

    Thank you Matt!!! I love this plugin and use it 2 other sites but I was creating a site for the local PTA using 2011 with a child theme and couldn't figure out what was going wrong! I did have to add my change as

    div#sb-container {
            z-index: 10000;
    }

    to get it to work correctly but you sure helped!

  11. Jacob "Boom Shadow" Tirey
    Member
    Posted 1 year ago #

    Editing wp-content/plugins/shadowbox-js/css/extras.css worked for me. Thanks so much for the fix Matt!

  12. vamapaull
    Member
    Posted 1 year ago #

    Matt Martz,

    Thank you!
    That worked just fine.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic