WordPress.org

Ready to get started?Download WordPress

Forums

Shadowbox JS
Images in posts not shadowboxing (5 posts)

  1. dameonjamie
    Member
    Posted 2 years ago #

    Hello,

    first of all please accept my thanks for making such a great plugin. I have used shadowbox by Michael Jackson for years on static html websites and now I use your plugin on my wordpress website. Thank you so much.

    Images in posts in a website I recently created are not "shadowboxing" but instead opening in the browser:

    http://www.amjphotocairns.com.au/blog

    Shadowbox is working on Galleries on other pages and I tried a single image on a page and that worked too. The problem seems to only be occurring in wordpress posts.

    Thank you.
    Dameon

    http://wordpress.org/extend/plugins/shadowbox-js/

  2. dameonjamie
    Member
    Posted 2 years ago #

    More Info:

    Shadowbox is not working on the Post page, the "Blog" page. However, if I look at an individual post, shadowbox is working.

    Posts page
    http://www.amjphotocairns.com.au/blog

    Individual post:
    http://www.amjphotocairns.com.au/archives/517

    Any ideas why the Post page is not working?

  3. fanta00
    Member
    Posted 1 year ago #

    I have the same problem, anyone got a solution for this?

  4. tonysmithdesign
    Member
    Posted 1 year ago #

    I'm not sure if this will help but I spent 2 days working on my issue which fell under the category "Images in posts not shadowboxing".

    I manage multiple sites and have been using Shadowbox JS on several of them. I installed the plugin on all of them using the WordPress Admin > Plugin panel. Until recently this was fine but the plugin failed to work on the latest site I'm in the process of building. To be more specific, the plugin partially worked but failed to open images in a light box. The plugin did generate the required (rel="shadowbox...") attribute for all links with images but for some reason images would only open in a page and not in a light box.

    My solution was to go to the author site (http://www.shadowbox-js.com/download.html) and download the source files manually. I selected all the player options, downloaded the source files, then uploaded only the shadowbox.js file to my server. I chose the location wp-content/plugins/shadowbox-js/js/shadowbox.js for my purposes but this shouldn't matter. Keep in mind, this is in addition to retaining the active version of the plugin already installed in the Admin panel.

    I then updated my header.php file to include a static reference to the shadowbox.js file AND included the Shadowbox.init(); call like below. I tried commenting them out individually and it turned out that both needed to be included for it to work. In addition, this update had to be included below the default <link> and <script> tags that the plugin generates.

    <link rel="stylesheet" type="text/css" href="http://oxygenfactor.com/site/wp-content/uploads/shadowbox-js/src/shadowbox.css">
    <script type="text/javascript" src="http://yoursite.com/wp-content/plugins/shadowbox-js/js/shadowbox.js"></script>
    <script type="text/javascript">
    Shadowbox.init();
    </script>

    So to summarize...

    1. Have Shadowbox JS plugin already installed.
    2. Go to http://www.shadowbox-js.com/download.html to download source files
    3. Upload only the shadowbox.js file to your server
    4. Place the included code below the default <link> and <script> tags that the plugin generates.

    Not sure if this helps everyone but it worked for me.

  5. semblance_er
    Member
    Posted 1 year ago #

    Thank you so much for your thorough step by step of what you've done.
    This was driving me nuts. Working perfectly from just plugin install on a different site I have done and now suddenly one I am doing now, it didn't work.
    Your method worked for me! Brilliant!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic