WordPress.org

Ready to get started?Download WordPress

Forums

Shareaholic | share buttons & related posts
[Plugin: SexyBookmarks] Warning: strpos() [function.strpos]: Offset not contained in string (13 posts)

  1. valandilearfalas
    Member
    Posted 3 years ago #

    Hi there,

    First of all, let me just say this is an awesome plugin. I've been using it for a while but recently ran into a snag.

    I am receiving this error:

    Warning: strpos() [function.strpos]: Offset not contained in string in /home/b-web/b7/fb/australiancreditcards.com.au/public/www/wp-content/plugins/sexybookmarks/includes/public.php on line 651

    Warning: strpos() [function.strpos]: Offset not contained in string in /home/b-web/b7/fb/australiancreditcards.com.au/public/www/wp-content/plugins/sexybookmarks/includes/public.php on line 194

    And it's apparently quite common, judging from a Google search.

    I've manually called sexybookmarks in a custom category page. Strangely though, some custom category pages are fine, while others display those errors.

    You can see an example of the error here: http://www.australiancreditcards.com....

    Thanks!

  2. Shareaholic
    Member
    Plugin Author

    Posted 3 years ago #

    @valandilearfalas are you still getting this error? Also, are you running the latest version of SB?

  3. valandilearfalas
    Member
    Posted 3 years ago #

    Yup, still getting the error if I enable the plugin. And yes, I was running the latest version.

  4. Shareaholic
    Member
    Plugin Author

    Posted 3 years ago #

    Can you try beta mode?

  5. Jive Dig
    Member
    Posted 3 years ago #

    Any luck getting shareaholic on your category pages? This is a must-have feature for my blog, which is based around category pages

  6. valandilearfalas
    Member
    Posted 3 years ago #

    When I try beta mode, I get this error in the admin panel:

    Warning: fopen(/home/b-web/b7/fb/australiancreditcards.com.au/public/www/wp-content/plugins/sexybookmarks/spritegen/media/js/jquery.shareaholic-publishers-api.min.js) [function.fopen]: failed to open stream: Permission denied in /home/b-web/b7/fb/australiancreditcards.com.au/public/www/wp-content/plugins/sexybookmarks/includes/helper-functions.php on line 150

    Warning: fopen(/home/b-web/b7/fb/australiancreditcards.com.au/public/www/wp-content/plugins/sexybookmarks/spritegen/api/sprite.css) [function.fopen]: failed to open stream: Permission denied in /home/b-web/b7/fb/australiancreditcards.com.au/public/www/wp-content/plugins/sexybookmarks/includes/helper-functions.php on line 150

    Warning: fopen(/home/b-web/b7/fb/australiancreditcards.com.au/public/www/wp-content/plugins/sexybookmarks/spritegen/api/sprite.png) [function.fopen]: failed to open stream: Permission denied in /home/b-web/b7/fb/australiancreditcards.com.au/public/www/wp-content/plugins/sexybookmarks/includes/helper-functions.php on line 150

    In the actual blog post, nothing appears. Turning off beta mode produces the original error.

    Thanks.

  7. Shareaholic
    Member
    Plugin Author

    Posted 3 years ago #

    @valandilearfalas you got the above error as permissions are currently set incorrectly.

    You need to set the /spritegen folder and all folders within it to permission 755 or 777 (some servers are fussy with 755 so pl. try both in case one doesn't work).

    Let us know how that goes.

  8. valandilearfalas
    Member
    Posted 3 years ago #

    Yup, tried both 777 and 775 and that message still appears. Strange. I upgraded to the latest version, 3.3.6, still the same.

  9. Shareaholic
    Member
    Plugin Author

    Posted 3 years ago #

    After you 777ed the spritegen folder and all folders within it, did you try to re-save your settings?

    Then after you re-saved your settings, were there .js/.css/.png files in the /spritegen folder?

  10. bmwau
    Member
    Posted 3 years ago #

    Hello,

    I'm having a similar problem with a new WP 3.1 build, which includes BuddyPress.

    Warning: strpos() [function.strpos]: Offset not contained in string in /home/egreen/public_html/wp-content/plugins/sexybookmarks/includes/public.php on line 209

    This looks like it relates to permalink setup for RSS feed links.

    What is the fix for this one?

    I've chmod'd all directories spritegen to 777; I've also chmoded all php scripts in includes/ to 777 so they are all executable, as I had that separate error issue with those.

    I kept the individual graphics files in those directories as 666, so they are writeable by the plugin scripts.

  11. enderandrew
    Member
    Posted 3 years ago #

    I'm in the exact same boat as bmwau.

  12. Thought Police Interactive Studios
    Member
    Posted 2 years ago #

    I wrote about a fix for the offset not contained in string error.

    The short version is pull out the following from the line of code throwing the error:

    , strlen($r['feed_permalink']) - 4

  13. Thought Police Interactive Studios
    Member
    Posted 2 years ago #

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic