WordPress.org

Ready to get started?Download WordPress

Forums

Shareaholic | share buttons & related posts
[resolved] [Plugin: SexyBookmarks] Something's wrong with 3.2.4 (15 posts)

  1. Jeff
    Member
    Posted 3 years ago #

    I updated to 3.2.4 today and now at the bottom of my posts i see a vertical line of little dots.

    As soon as I deactivate the plugin, the dots go away. I have not change any other plugins prior to the 3.2.4 update, so I can't blame it on another plugin.

    Is anyone else having a problem? It happens in both Chrome 6.0.487.0 (55176) and FF3. I'm running WP locally on Ubuntu 10.04.

  2. intographics
    Member
    Posted 3 years ago #

    Windows 7
    FF 3.6.8 : OK.
    IE 8.0.7600.16385 : dots vertically
    Opera 10.60 : dots vertically
    Dots do *not* disappear after deactivating the plug-in.
    There are no dots in the HTML source code.
    EDIT: The dots appear where we normally would see (the regular?) sexy stuff.

  3. intographics
    Member
    Posted 3 years ago #

    Problem is gone. Don't know what caused it. This kind of stuff is happening a lot. WP 3.0.1 looks like a little troublemaker. The update process yesterday cost me donkeys years and umpteen attempts.
    But let's be/stay grateful.

  4. Josh Jones
    Member
    Posted 3 years ago #

    @Jeff & @intographics:

    We're relying on the function wp_footer() to be in the footer.php file of your theme in order to ensure that the JS inection happens AFTER the rest of the scripts have loaded into the page.

    Please check your themes and ensure that your footer.php does in fact have <?php wp_footer(); ?> just BEFORE the </body> tag.

  5. chovy
    Member
    Posted 3 years ago #

    I am getting the same problem.

    It appears the css is not getting applied correctly (nor the js).
    ALl I did was upgrade the plugin. I also switched to WP Total Cache, so perhaps there is a setting (defaults) that need to be modified for SexyBookmarks to work?

  6. chovy
    Member
    Posted 3 years ago #

    <link rel='stylesheet' id='sexy-bookmarks-css' href='http://www.example.com/wp-content/plugins/sexybookmarks/spritegen/shr-custom-sprite.css?ver=3.2.4' type='text/css' media='all' />

    This spritegen folder exists, but it is empty.

  7. chovy
    Member
    Posted 3 years ago #

    Enabling Beta mode and clicking save appears to fix the problem.

  8. oceanwidedesigns
    Member
    Posted 3 years ago #

    I'm having the same issue after upgrading, never had a problem before. Running WP Total Cache & Thesis.

  9. ucero
    Member
    Posted 3 years ago #

    Today I updated the plugin. Works well in IE, Firefox, Chrome, Opera and Safari. The beta version has many errors.

  10. Vakantie Ameland
    Member
    Posted 3 years ago #

    With version 3.2.4.1 I have the same issue. The message about the header and footer calls. They are wrong because they are in exactly the right place.

    And the Sexy Bookmarks do not function anymore. When I click I do get the message:

    An Error Was Encountered

    The short_link field must contain a valid URL.

  11. Mike Wilson
    Member
    Posted 3 years ago #

    I get the incorrect WP header and footer errors, but otherwise the plugin seems to be working fine for me. I'm using it on a client's site tho... so I had to deactivate it until we get a fix.

    SexyBookmarks 3.2.4.1 & WordPress 3.0.1

  12. Josh Jones
    Member
    Posted 3 years ago #

    To Anyone Recieving the Warning Messages:
    We have removed the wp_footer and wp_head warnings as they were returning too many false positives. Please upgrade to v3.2.4.2 to alleviate that issue.

    To Anyone Showing Bullets:
    There are 3 primary possibilities causing this one:

    1. Browser cache.
      • Clear your cache
      • Refresh twice (hard refresh)
    2. Custom sprite image/css deleted upon upgrade.
      • Save your settings again in order to fetch the custom sprite image/css via the API
    3. Directory permissions.
      • If NOT using BETA:
        • Make sure your spritegen folder is CHMOD'd to either 755 or 777 based on your server setup
      • If you ARE using BETA:
        • Ensure the spritegen folder is CHMOD'd to either 755 or 777 based on server setup
        • Ensure that spritegen->media is CHMOD'd to either 755 or 777 based on server setup
        • Ensure that spritegen->api is CHMOD'd to either 755 or 777 based on server setup
        • Ensure that spritegen->media->js is CHMOD'd to either 755 or 777 based on server setup

    To Anyone Having Issues With Short URLs:
    Please try selecting either TinyURL or b2l, as well as selecting the "Clear all short URLs" option and save your changes.

    If the short URL problem persists, please let me know here: http://getsatisfaction.com/shareaholic/products/shareaholic_shareaholic_for_wordpress_sexybookmarks

  13. boombatze
    Member
    Posted 3 years ago #

    Solution 2 solved the problem in my case ...

  14. P3air
    Member
    Posted 3 years ago #

    http://www.p3air.com, Sexy BM 3.2.4.2 (beta) - WP 3.0.1

    all the sudden we had the same issue:

    An Error Was Encountered

    The short_link field must contain a valid URL.

    Fix: switched to "tinyurl.com", save (2x), then back to "b2l.me", save (2)

    works again

    Hope that works for others too
    cheers

  15. AYHJA
    Member
    Posted 3 years ago #

    I only got the "The short_link field must contain a valid URL." error when I tried the BETA version, when I switched it back it worked fine...

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic