WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: SexyBookmarks] Option for opening links in new window is not working (4 posts)

  1. Rafael Fischmann
    Member
    Posted 4 years ago #

    Even though it's enabled in the settings, nothing changes in the site.

    http://wordpress.org/extend/plugins/sexybookmarks/

  2. Rafael Fischmann
    Member
    Posted 4 years ago #

    I did this manually editing the plugin's code, but it would be nice if it worked via the settings.

  3. eight7teen
    Member
    Posted 4 years ago #

    Hmm, it's working on my end... What browser are you using and what version of the plugin?

    The problem could lie within the method in which we're calling the new window... Rather than using "target=_blank" (which is deprecated now), we're using javascript/jquery to set the attribute on the fly via the DOM without ruining the validity of the links.

    If you don't have either the animate-expand or auto-center functions selected, then the javascript won't even be loaded when the page loads, so I'm assuming that would be why the new window isn't working properly.

    I will work on separating that function from the other JS so that it will load even if the others aren't selected.

    Thank you for bringing this to my attention.

  4. Rafael Fischmann
    Member
    Posted 4 years ago #

    Firefox 3.5, latest version of plugin, I downloaded and installed it a few hours ago.

    Yeah, I did add target="_blank" manually, because I didn't see it in the code. That's how it's working now in my site.

    And you probably got why it's not working, both of that options are disabled in my config., and I don't really want to turn them on.

    I'll wait for the next update, then. While it doesn't come, I'll leave the target="_blank" there. Thanks!

Topic Closed

This topic has been closed to new replies.

About this Topic