WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [Plugin: SexyBookmarks] Latest v 3.0 trigger fatal error (10 posts)

  1. Truth
    Member
    Posted 4 years ago #

    I just updated to the latest version 3.0 and it triggers a fatal error and plugin cannot be activated:

    Parse error: syntax error, unexpected '.' in /.../plugins/sexybookmarks/sexy-bookmarks.php on line 209

    I downgraded back to 2.6.1.3 for now.

    Any fixes for this?

    http://wordpress.org/extend/plugins/sexybookmarks/

  2. Josh Jones
    Member
    Posted 4 years ago #

    I’m sorry about that… Looks like I missed something in my rush to get the version released… I’ve updated the SVN, so please delete the copy you’re using now and redownload to fix the issue.

    Again, sorry!

  3. MacItaly
    Member
    Posted 4 years ago #

    Thanks Josh, now works.

  4. Truth
    Member
    Posted 4 years ago #

    I redownloaded and the plugin can be activated (thank you for fixing that!) but when I save changes on the plugin page. I get this error at the top:

    Warning: filesize() [function.filesize]: stat failed for /.../plugins/sexybookmarks/images/icons/sexy-google.png in /.../plugins/sexybookmarks/includes/sprite-gen/classes/SpriteImage.php on line 21

    and on my post, no icons shows up. I think the sprite image was not being created due to the error.

    I unchecked "Google Bookmarks" in the settings and there was no more errors. But the background still did not show up.

    According to the source code, the background URL in the CSS is:

    http://domain.com/plugins/sexybookmarks/images/ed65cf16eb05518181274adfbb3101d6.png

    but my WordPress was installed in a folder so the correct URL should be

    http://domain.com/folder-name/plugins/sexybookmarks/images/ed65cf16eb05518181274adfbb3101d6.png

    Any way to fix this? I'm pretty sure not everyone has WP installed on their root folder. Thanks!

  5. Josh Jones
    Member
    Posted 4 years ago #

    Yea, actually I had made sure to put a check in for subdirectory installs... I'll test it again to make sure... Give me a bit to figure it out... I'm kinda inundated with support requests from my goof this morning.

    You may want to downgrade until I release a bug patch.

    Sorry.

  6. Truth
    Member
    Posted 4 years ago #

    No problem! I will downgrade till this is fix.

    Thanks so much for taking the time and effort to do this. It's really appreciated. :)

  7. Josh Jones
    Member
    Posted 4 years ago #

    Problem fixed in v3.0.1

  8. markkaz
    Member
    Posted 4 years ago #

    ver 2.6.1.3 doesn't work with cache again. CSS is gone

  9. markkaz
    Member
    Posted 4 years ago #

    Actually it is not 2.6.1.3 which has problem, but WP AutoUpdate loads ver 3.0.1 which is broken.

  10. Josh Jones
    Member
    Posted 4 years ago #

    I would suggest talking to the owners of "WP AutoUpdate" because I've already updated the "stable tag" for SexyBookmarks to reflect the older version in order to prevent any further problems until we can get this latest release bug free...

    It would appear that they're not checking the stable tag of a plugin to see if there are updates available. They are most likely using a version comparison and comparing which version number is larger.

Topic Closed

This topic has been closed to new replies.

About this Topic