WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [Plugin: SexyBookmarks] I love Sexybookmarks, but it doesn't display properly on my theme (9 posts)

  1. TwistedSifter
    Member
    Posted 4 years ago #

    Hello awesome creators of SexyBookmarks!

    I reinstalled the latest version of your fantastic plugin after the previous version was doing weird things to my site.

    All is good and it looks great, however it seems to display very strangely. I had this problem before and you were able to resolve the issue, but it is occurring again with this latest version any thoughts?

    my site: http://www.twistedsifter.com

    the problem: every time I turn on the plugin, it won't display until all of the content on the left-side column of my website displays (i.e., after the wooden facebook icon on the left-side)

    so if you look at any page, for example: http://twistedsifter.com/2009/12/the-sunday-selection-13/

    the bookmarks won't display until the very bottom of the post after all of the content on the left-side has displayed.

    Last time you said to alter the CSS for div.sexy-bookmarks-expand to:
    {
    clear:right;
    height:29px;
    overflow:hidden;
    }

    but it doesn't seem to work.

    any suggestions?

    Thanks so much for your help. it really is a great looking plugin, i would love to use it!

    http://wordpress.org/extend/plugins/sexybookmarks/

  2. eight7teen
    Member
    Posted 4 years ago #

    Hi there, you should look into reworking your theme a bit... As the theme is what's actually "causing" the issue... It's just not noticeable until you add in this plugin.

    At any rate, you can select the "use custom mods" option and then edit the file style.css that should be located in wp-content/sexy-mods/css

    find:

    div.sexy-bookmarks {
    display:block;
    margin:20px 0 0;
    }

    and replace it with:

    div.sexy-bookmarks {
    clear:right;
    display:block;
    height:29px;
    margin:20px 0 0;
    }

    That should work for now.

  3. TwistedSifter
    Member
    Posted 4 years ago #

    Thanks so much for the response eight7teen! i'll be making a donation for your efforts regardless if i can get it working on my site or not. i can only imagine how many emails/requests you get for a 'FREE' plugin. anyway your help is appreciated.

    i think you are right, i need to have someone review my theme coding and fix it up.

    in the meantime i tried your suggestion above to the style.css in sexybookmarks but it's still loading beneath all of the content on the left-side column.

    my file looks like this:

    div.sexy-bookmarks { clear:right; display:block; height:29px; margin:20px 0 0; }
    div.sexy-bookmarks-expand { height: 29px; overflow: hidden; }

    in my wordpress dashboard i checked the following box:
    Override Styles With Custom Mods Instead? YES

    Any ideas?

    thanks!

  4. evertjan
    Member
    Posted 4 years ago #

    I have a similar problem when I use this plugin on Onbezet.nl with the P2 theme. The fix mentioned above does not seem to work for me.

  5. eight7teen
    Member
    Posted 4 years ago #

    @TwistedSifter:
    Try this:
    div.sexy-bookmarks {
    clear:right !important;
    display:block;
    height:29px !important;
    margin:20px 0 0;
    }

    @evertjan:
    I don't see the plugin anywhere on that site you linked to... Would you mind submitting a bug report via this form: http://sexybookmarks.net/contact-forms/bug-form so that I can get a better idea for the setup you're using and the exact nature of the problem? Thanks.

  6. evertjan
    Member
    Posted 4 years ago #

    @eight7teen:
    I enabled it again and managed to show it at the right place with:
    div.sexy-bookmarks {
    clear:left !important;
    display:block;
    height:29px !important;
    margin:20px 0 0;
    }

    I suppose I have to make the manual change each time there is an update...

    Thanks for your support.

  7. TwistedSifter
    Member
    Posted 4 years ago #

    Hi eight7teen,

    Thanks for your reply. I tried your suggestion above but it still loads strangely.

    My style.css looks like this:
    div.sexy-bookmarks { clear:right !important; display:block; height:29px !important;
    margin:20px 0 0; }
    div.sexy-bookmarks-expand { div.sexy-bookmarks-expand { height: 29px; overflow: hidden; }

    If you look at this page: http://twistedsifter.com/2009/12/picture-of-the-day-december-20-2009/

    The bookmarks still don't load until the very bottom. There must be something weird with my theme code.

    Any ideas?

    Thanks for your help eight7teen!

    ps. a donation has been made for your efforts. it is truly appreciated. Even if the plugin doesn't work for me at the moment, eventually it will!

  8. eight7teen
    Member
    Posted 4 years ago #

    @evertjan:
    Actually, you won't... You can simply put a check in the box that says "Override styles with custom mods?" and then save your changes. You will then need to navigate to wp-content/sexy-mods/css and edit the style.css file that was copied from the plugin folder to add the code you said you were able to make work.

    These changes will then be available even if you upgrade the plugin because the folder/files are NOT located within the plugin's original directory, and as such, they will not be removed or overwritten when you upgrade.

    @TwistedSifter:
    You'll need to find this file: http://twistedsifter.com/wp-content/sexy-mods/css/style.css

    Once you've located it, simply edit the first line which should currently look like this:

    div.sexy-bookmarks {
    clear:both !important;
    margin:20px 0 0;
    }

    Simply replace that chunk of code with:
    div.sexy-bookmarks {
    clear:right !important;
    height:29px;
    margin:20px 0 0;
    }

  9. TwistedSifter
    Member
    Posted 4 years ago #

    pure awesomesauce. i was editing the wrong file. you sir are the BEST! thank you :D

Topic Closed

This topic has been closed to new replies.

About this Topic