WordPress.org

Ready to get started?Download WordPress

Forums

Shareaholic | share buttons & related posts
[resolved] [Plugin: SexyBookmarks] Error share api not found (15 posts)

  1. Vakantie Ameland
    Member
    Posted 3 years ago #

    When I use the latest version 3.2.11 only the twitter button redirects to the right site (twitter.com) when I click.

    All the other buttons (like facebook, linkedin) redirect to a page not found on my own website /share/api . Must be something wrong with the redirection in the code caused by the new share api introduction....

    Happens in beta and non beta use. None of the javascript for the sexybookmarks-plugin is cached

    http://wordpress.org/extend/plugins/sexybookmarks/

  2. Shareaholic
    Member
    Plugin Author

    Posted 3 years ago #

    Hi christianebuddy, this is very unusual. can you point me to a sample webpage where this is happening so i can take a look?

  3. Vakantie Ameland
    Member
    Posted 3 years ago #

    I downgraded to the previous version, which was working perfectly, don't want to interact with user experience for bad url's etc... The site is http://vakantie-in-ameland.nl

  4. Shareaholic
    Member
    Plugin Author

    Posted 3 years ago #

    Possible that you can upgrade again? We'd really like to fix this!

  5. Vakantie Ameland
    Member
    Posted 3 years ago #

    I just did. So if you can look at it now, the user will not experience difficulties for a long time?

    Tnx!

    Problem is there again!

  6. Shareaholic
    Member
    Plugin Author

    Posted 3 years ago #

    We're taking a look now.

  7. Shareaholic
    Member
    Plugin Author

    Posted 3 years ago #

    @christianebuddy, can you please try to reset your SB settings? We think your database entries may be corrupt, and resetting should fix that. We realize it's a pain to do so, but we think that should fix it. Let us know!

    ps. have you tried the beta yet?

  8. Vakantie Ameland
    Member
    Posted 3 years ago #

    That did the trick! Adjusted it after a lot of clicking ;-) to my needs

    Tnx!

    Tried to use the beta version, but when I try it, the SB links in the bottom of the page are not there, so that part does not work. Conventional method works though

  9. Shareaholic
    Member
    Plugin Author

    Posted 3 years ago #

    That's great!

    btw, we will be switching completely over to the new code (current "beta") very soon. It would help if you could give it a deeper look.

  10. Vakantie Ameland
    Member
    Posted 3 years ago #

    Well, you can investigate the Beta problem. I just switched to the Beta version. Wonder what might cause that problem.

  11. Shareaholic
    Member
    Plugin Author

    Posted 3 years ago #

    Here is the issue, this file is missing:

    http://www.vakantie-in-ameland.nl/wp-content/plugins/sexybookmarks/spritegen/media/js/jquery.shareaholic-publishers-api.min.js

    This usually happens when directory permissions are not set correctly. The spritegen folder needs to be CHMOD either 755 or 777. Once you make the change, simply re-save your settings in order to pull the latest file from the server! Let us know how it goes.

  12. Vakantie Ameland
    Member
    Posted 3 years ago #

    And the subdirectories as well otherwise the file isn't generated and written. But that does not solve the problem as nothing shows

  13. Shareaholic
    Member
    Plugin Author

    Posted 3 years ago #

    Two more 404s (the actual images/css):

    http://www.vakantie-in-ameland.nl/wp-content/plugins/sexybookmarks/spritegen/api/sprite.css

    http://www.vakantie-in-ameland.nl/wp-content/plugins/sexybookmarks/spritegen/api/sprite.png

    btw, fixing this will also make "regular" mode much faster. Earlier you were not taking advantage of our image sprites. So you were loading all 60+ images vs. just the ones you chose to display!

  14. Vakantie Ameland
    Member
    Posted 3 years ago #

    Indeed I had to chmod this directory as well. Now the SB is flying... Tnx for that..

    Think it would be necessary to automatically chmod the needed folders as I am not the only one using SB on a linux server ;-)

  15. Shareaholic
    Member
    Plugin Author

    Posted 3 years ago #

    Great!

    The issue with automatic chmod is that frequently non-dedicated servers won't allow scripts to change directory permissions. Let us know if you think of a workaround!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic