WordPress.org

Ready to get started?Download WordPress

Forums

Shareaholic | share buttons & related posts
[resolved] [Plugin: SexyBookmarks | email, bookmark, share buttons] I got the Google +1 Button working!! (3 posts)

  1. Flybuzz
    Member
    Posted 2 years ago #

    Alright guys, after fighting with it for 5 hours, for now it appears as if it's working for me. There are lots of steps you can try for youself. It is for the latest version right now 5.004

    I tried to install the latest version on 2 sites, both of them didn't have the google + button showing at first. So I am pretty sure there is a bug some where. So the solution will be divided to 2 parts based on type of your site that you have.

    Before you start, make sure you have minimum 2 browsers. I have 4 browsers to test because my site is heavily cached. I use IE, Chrome, Firefox and my Iphone for testing. Sometimes they will show different results.

    #1 If your site is not too heavily cached, I saw this suggestion by someone in the forum. Turn the option Use "new mode"? off. Save it. Refresh your homepage and your Google +1 Button should be showing up. If it's not, then refresh it, clear browser cache, refresh it some more and try on different browsers. It should be back at this point. But that is not the hard part. Now you want to turn on the Use "new mode"? again. Now see if the Google +1 Button stays or not. If it's still there and also try it with some other browser and if it's also there, congrats you have fixed it. If not keep reading.

    #2 If you are using W3 Total Cache and cloudflare like me, your site will be heavily cached. Disclaimer: I am not familiar with how sexybookmark work internally nor its coding, I am just saying the following worked for me.

    I am assuming you have already selected your favorite buttons in the sexybookmark page and probably will not need to change soon.
    Goto http://www."yourwebsiteurlhere".com/wp-content/uploads/shareaholic/spritegen/sprite.png with your browser and then zoom in on the png. Scroll through all the little button pictures and you should have the google+ button near the end.

    Now Use your fav FTP program browse to /public_html/wp-content/uploads/shareaholic/spritegen/ folder and then save sprite.css and sprite.png to your desktop.

    Now delete all files and folders underneath /public_html/wp-content/uploads/shareaholic/spritegen/ that should be index.html and the spritegen folder.

    Now go to the /public_html/wp-content/plugins/sexybookmarks/spritegen_default and rename the original
    sprite.css and sprite.png to some other backup name like sprite-old.css and sprite-old.png and copy the files you have at your desktop to this folder.

    If you are using cloudflare, turn on development mode, purge cache, turn off rocket loader and then empty all cache in W3 Total Cache, empty all cache in the browser you are using for testing. Now try to load your website in at least 2 browsers. The google+ buttons should come out now in at least 1 site. The more browsers you have the better you can confirm that the +1 button is working and it's just a matter of closing and reopening browsers, clear the cache again to help it bring it out. I hope that helps for you.

    http://wordpress.org/extend/plugins/sexybookmarks/

  2. kletskater
    Member
    Posted 2 years ago #

    man you rock.........
    thanks..........

  3. DaniLew
    Member
    Posted 1 year ago #

    This was very helpful, Flybuzz! I was getting so frustrated and your solution with the W3 Total Cache worked to perfection.

    Thank you!

    Danielle

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic