WordPress.org

Ready to get started?Download WordPress

Forums

Shareaholic | share buttons & related posts
[Plugin: SexyBookmarks | email, bookmark, share buttons] Google +1 Button Not Rendering (12 posts)

  1. Reinharts
    Member
    Posted 2 years ago #

    Hey!
    I was so excited to see that the new version included a G+ button in the sex bookmarks.

    Over at HBOWatch.com you can see that I have the G+ button in my options but it is just blank on the page.. (scroll over it's on the end to see)

    Any ideas here? Would love to see it working.

    Thanks!

    Jacob
    HBOWatch.com

    http://wordpress.org/extend/plugins/sexybookmarks/

  2. Reinharts
    Member
    Posted 2 years ago #

    Also.. not seeing the button in the Sprite.png at all.. Can anyone else get the new G+ button to show?

  3. Reinharts
    Member
    Posted 2 years ago #

    Okay so I added it manually to the sprite.png (not sure what else to try?) and it still didnt work. Any other ideas?

  4. Reinharts
    Member
    Posted 2 years ago #

    NM fixed it myself.. had to add it manually to the sprite at position 304 (because it isnt there) and then add these lines to sprite.css under "Edit Plugin" (because they arent there..)

    li.shr-304{background-position:-18240px bottom !important}li.shr-304:hover{background-position:-18240px top !important}

    Cheers.

  5. Celeste - Shareaholic
    Member
    Posted 2 years ago #

    Well, kudos for correcting the error! :)

    In case you encounter this issue again, re-saving from the configuration page will refresh the dynamic sprite sheet and usually fixes this problem.

  6. Vakantie Ameland
    Member
    Posted 2 years ago #

    How do you add the G+ button manually to the Sprite.png image?

    Maybe it's better to solve it in the plugin in a corrected version?
    Re-saving (couple of times) does not solve this issue.

  7. kletskater
    Member
    Posted 2 years ago #

    this workaround works for me perhaps for you also

  8. Celeste - Shareaholic
    Member
    Posted 2 years ago #

    @christianebuddy

    If the issue isn't due to caching and resetting your SexyBookmarks settings doesn't work, try reinstalling the plugin.

  9. enderandrew
    Member
    Posted 2 years ago #

    The G+ sprite doesn't show up for me. I cleared my WP cache, my mod-pagespeed cache and browser cache. I can see it in my sprite.png file, but it isn't showing up on the site.

  10. Reinharts
    Member
    Posted 2 years ago #

    Just an update. Still had to do this with the new 6.0 version.

    If you need an edited PNG (that actually includes the +1 button.. mine didnt either time..) grab mine.

    http://i.imgur.com/WoOks.png

    Made it custom to use with the code:

    li.shr-304{background-position:-18240px bottom !important}li.shr-304:hover{background-position:-18240px top !important}

    Add those lines to the end of your sprite.css file and then overwrite the default (wrong?) sprite.png image in the spritegen_default folder of the plugin.

    Should fix it. Not sure why Sharaholic hasn't fixed this. Might just be a theme issue. Anyway.. the above works for me.. have to do it every time the plugin updates :(

  11. Shareaholic
    Member
    Plugin Author

    Posted 2 years ago #

    @All we will be releasing a plugin update in the next 5-7 days that should fix this on our end. Thanks so much for discovering this bug and your patience!

  12. phil@silverstar-media.com
    Member
    Posted 1 year ago #

    Just installed version 6.0.0.3 on clean wordpress 3.5 install today, and I ran into the same thing. Thanks, Reinharts, for the fix! It worked perfectly. It's just odd that though Shareaholic intended to address this over 5 months ago, still nothing has changed.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic