WordPress.org

Ready to get started?Download WordPress

Forums

Shareaholic | share buttons & related posts
[resolved] [Plugin: SexyBookmarks | email, bookmark, and share buttons] Fopen Error When Save Changes and Permi (9 posts)

  1. ibc3
    Member
    Posted 2 years ago #

    Hi! I am running WP 3.3 & Sexybookmarks 4.0.6.4. I recently backed up the files & database of this site, re-installed on a new server, and modified locations in the database to accommodate the new location/url. I updated WP & all plugins to the current version.

    For Sexybookmarks, when I Save Changes on the settings page, I get several variations (10 to be exact) of the following error:

    Warning: fopen(/sitename.com/wp-content/uploads/shareaholic/spritegen/jquery.shareaholic-publishers-sb.min.js) [function.fopen]: failed to open stream: No such file or directory in /home/content/52/5919852/html/sitename.com/wp-content/plugins/sexybookmarks/includes/shrsb_settings_page.php on line 368

    In the Compatibility Settings, I have the Custom Path set to
    /sitename.com/html/wp-content/uploads/shareaholic/
    and the Default Path (which I cannot change on this page) says
    /home/content/52/5919852/html/sitename.com/wp-content/uploads/shareaholic/
    The previous installation of this site had both the custom & default as
    /home/content/a/n/n/sitename.com/html/wp-content/uploads/shareaholic/

    I have noticed that when I change the Custom Path, the path name in the fopen part of the above error changes. The path name in the "no such file or directory" part always shows the default path.

    I have also changed the following directories to have 777 permissions; I know some were not part of the instructions, but I tried anyway to see if it would help:
    wp-content/plugins/sexybookmarks/spritegen
    wp-content/plugins/sexybookmarks/css
    wp-content/plugins/sexybookmarks
    wp-content/uploads/shareaholic
    wp-content/uploads/shareaholic/spritegen

    Yet, on the Plug-in Health Status, it still shows Directory Permissions as red with the message "To Fix: Please appropriately CHMOD your /spritegen directory.

    Oh, to try to rectify some of these errors, I also deleted the sexybookmarks directory & reloaded with the download from the webiste, but it didn't help.

    So, can anyone tell me:
    1. Why am I getting the fopen error message & how do I fix it?
    2. Why does Sexybookmarks still think that the permissions have not been changed?
    3. What does the /home/content/a/n/n or home/content/52/5919852/html part of directory structure of the default & custom path mean? Where does the default get set?

    TIA!!

    http://wordpress.org/extend/plugins/sexybookmarks/

  2. Celeste - Shareaholic
    Member
    Posted 2 years ago #

    Hi! Could you please direct me to your blog, so that I can review this issue? Thanks!

  3. ibc3
    Member
    Posted 2 years ago #

    Thanks! Right now, I have it set up in a test location.
    dd.centnerconsulting.com

    It appears to be working fine, it's just the errors that are appearing on the admin settings page.

  4. ibc3
    Member
    Posted 2 years ago #

    Just moved to production anyway. Site is now
    dunawaydietetics.com

    I will be setting up another test site that is a backup of this one. I could even set up an admin account for you on the test one if you are willing to look at it. Thank you so much!

  5. Celeste - Shareaholic
    Member
    Posted 2 years ago #

    Hi! This query seems familiar, and I am wondering if it is being handled via email from support@shareaholic? If not, I am here to assist, and we can work on troubleshooting.

  6. ibc3
    Member
    Posted 2 years ago #

    Hi! Yes, this is the same as the support thread. Sorry, I think I posted this after I sent the email, not sure of which was the preferred method. We can close this and continue with the email. I just sent you an email update. Thanks so much!!

  7. HaveAnEpiphany
    Member
    Posted 2 years ago #

    I'm having the exact same issue after a very similar process (backup, upgrade, move to new server).

    Can you post the solution?

  8. ibc3
    Member
    Posted 2 years ago #

    Hi, HaveAnEpiphany! I just got a resolution yesterday from support, just tried it, & it worked! It was something that I thought I had already tried, but obviously I hadn't. Basically, in the settings, make the custom path identical to the default path.

    I'm not sure why if the custom path is empty that the plugin doesn't use the default path, but apparently the custom path needs to be set.

    Hope this helps. Thanks to C Reign for my resolution!

  9. HaveAnEpiphany
    Member
    Posted 2 years ago #

    Thanks so much for sharing this, ibc3!

    Turns out I had completely failed to notice that setting. It still contained a value from the old server. Now that I've changed it, the problem is resolved. Thanks! (And thank you to shareaholic support as well!)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic