WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [Plugin: SexyBookmarks] Does not display right underneath content (9 posts)

  1. TwistedSifter
    Member
    Posted 4 years ago #

    Firstly, I love this plugin. It looks fabulous and is highly functional.

    I have one slight issue which I think is an easy fix but my css/html knowledge is quite limited.

    I'm using a custom theme an acquaintance designed. I use this plugin at the bottom of each post I write. The problem is that the bookmarks will only display beneath/after all of the images/content on my left-hand sidebar.

    It may be easiest to just visit my site (http://TwistedSifter.com). Any post I write, the sexybookmarks will only display after my little twitter icon on the left-hand column.

    Any idea why?

    Any help is greatly greatly appreciated.

    Thanks! You guys rock

    http://wordpress.org/extend/plugins/sexybookmarks/

  2. eight7teen
    Member
    Posted 4 years ago #

    Looks like something in your theme is floated that shouldn't be...

    I couldn't find it, but here is a fix that works on my end until you can find the culprit...

    Using any plain text editor, open the stylesheet that comes with the plugin (style.css)

    Now look for the following:

    div.sexy-bookmarks-expand {
    clear:both;
    height:29px;
    overflow:hidden;
    }

    Just change the above code to the following:

    div.sexy-bookmarks-expand {
    clear:right;
    height:29px;
    overflow:hidden;
    }

    That should do it

  3. TwistedSifter
    Member
    Posted 4 years ago #

    Greetings eight7teen!

    Thanks so much for replying I really appreciate your time and help :D

    I tried inserting the code above into the style.css of sexybookmarks but nothing changed on my end. I am on my work computer though (IE7) and it tends to not load sites very nicely....

    In the code above as well, I did find the section of style.css that started with div.sexy-bookmarks-expand

    but in the code there was no line for: clear:both; to begin with, I added it anyway.

    Thanks! You rock

  4. TwistedSifter
    Member
    Posted 4 years ago #

    to clarify, I added clear:right; (not clear:both;)

    thanks!

  5. eight7teen
    Member
    Posted 4 years ago #

    Sorry about that...

    Change it to clear:none !important

    Then disable the two javascript required options (auto-center and animate expand) since neither are actually being used in your wide layout.

    After disabling those, delete everything in the custom CSS textarea and replace it's contents with this:

    display:block !important;
    height:29px !important;
    clear:none !important;

    Let me know if that does the trick!

  6. TwistedSifter
    Member
    Posted 4 years ago #

    Thank you so much eight7teen! It works great now. I can't thank you enough for your help :D

  7. modcom
    Member
    Posted 4 years ago #

    I have a related problem. On my blog -- http://moderncomfortfood.com, using Thesis Theme -- I already have Similar Posts placed at the bottom of each individual post. I have just installed the Sexy Bookmarks plugin, and it displayed AFTER Similar Posts. Is there some way to reverse the display order of these two plugins? Sexy Bookmarks should definitely immediately follow the actual post. Many thanks in advance.

  8. eight7teen
    Member
    Posted 4 years ago #

    You should be able to use "manual mode" to display the menu wherever you'd like...

    If you want it displayed directly beneath the post, but BEFORE anything else, I would recommend using the manual mode option... This will allow you to edit the single.php file and place the proper code into the file so that it will be displayed there BEFORE any plugins hook into the wp_content() hook.

  9. evertjan
    Member
    Posted 4 years ago #

    I am using the P2 theme from Automattic on http://onbezet.nl . The SexyBookmarks plugin is shown at the very bottom of the page, where I want it to appear directly after the post content. I tried the css fixes mentioned above, but that did not work for me.

    Anyone can help me out?

Topic Closed

This topic has been closed to new replies.

About this Topic