WordPress.org

Ready to get started?Download WordPress

Forums

Shareaholic | share buttons & related posts
[Plugin: SexyBookmarks] Broken after upgrade to version 3.2.7 on multisite 3.0.4 (6 posts)

  1. popo_blogai
    Member
    Posted 3 years ago #

    Broken after upgrade to version 3.2.7 on multisite 3.0.3 , sharing icons do not display, instead of this giving text list with links. This does not depend on theme which is used. Simple overwrite with earlier version does not help to solve this.

  2. popo_blogai
    Member
    Posted 3 years ago #

    It seems that the problem is related to spritegen folder which becomes do not writeable after upgrade.

    And also the other problem (seems only multisite related), that somehow it begins displaying same icons for different links, e.g., for all the links like share by email, by twitter, facebook, etc., it displays the same icon, for example, email icon. Sometimes this changes, but I do not know, why.

    Currently I can observe this strange behaviour with icons on this page:
    http://uzkalnis.popo.lt/2010/12/21/senas-straipsnis-arogantisku-neismaneliu-respublika/

  3. Shareaholic
    Member
    Plugin Author

    Posted 3 years ago #

    @popo_blogai

    Can you try a couple of things:

    - Make the folders writable
    - Re-save your SB settings (this will re-pull the css and image files from the server again)

    Right now there is a mismatch between the css and sprite file.

    ex. http://uzkalnis.popo.lt/wp-content/plugins/sexybookmarks/spritegen/shr-custom-sprite.png (no yahoo mail, or stumbleupon present)

    Let me know how this goes.

  4. jmbis
    Member
    Posted 3 years ago #

    this plugin is not compatible with wp ms (WordPress Multi Sites)

  5. popo_blogai
    Member
    Posted 3 years ago #

    Huh, yes, I resaved settings and understood where the problem lays. Yes, it seems that it is simply not multisite-compatible, so when some different blogs use this plugin, they interfere, because there is only one sprite image for them all.

    Is there any solution for this problem? It would be great to have this plugin for our community, because it is the Best.

  6. popo_blogai
    Member
    Posted 3 years ago #

    And after new upgrade that problem with writability seems to persist, but in other way - it shows, but do not allows to change. Maybe it can solved by change of folder permissions in distribution archive/

    And about multisite - can it be solved simply by use of different sprite configuration for multisites? I hope, this can be some hack, something to test if multisite is used and in case of true, using full sprite with all the icons? As far, as I currently understand, the problem only lays in image?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic