WordPress.org

Ready to get started?Download WordPress

Forums

SEO Ultimate
[resolved] "Notice: Undefined index ..." showing up in body HTML (4 posts)

  1. trijammer
    Member
    Posted 2 years ago #

    Especially with the Open Graph module (which I've had to disable until I can find a way to fix this / a patch is released), this plugin spits out multiple "Notice: Undefined index" errors that make their way to the page's HTML.

    With these errors not being caught before output, they are wreaking havoc on page layout. They are not staying in the <head> area, but (as they are untagged text) are bumping down into the top of the <body>, along with all following meta tags. This effectively negates all meta-related SEO.

    The specific error I've come across last is: "Notice: Undefined index: twitter in /***wordpress/wp-content/plugins/seo-ultimate/modules/opengraph/opengraph.php on line 211".

    This shows up twice; before twitter:card and before twitter:site meta tags, which are bumped into the <body> by this error text.

    Googling "undefined index"+"/wp-content/plugins/seo-ultimate/modules/" will show a fair few people with this problem, active, relating to a number of different code lines and modules.

    Any ideas?

    Thanks.

    http://wordpress.org/extend/plugins/seo-ultimate/

  2. John
    Member
    Plugin Contributor

    Posted 2 years ago #

    The errors should be removed in 7.5.6. The errors only appeared on sites that had the WP_DEBUG setting enabled in the wp-config.php file (WP_DEBUG is not supposed to be enabled on live sites).

  3. trijammer
    Member
    Posted 2 years ago #

    Great, thanks for your feedback John. Much appreciated. The issue is fixed with the update as you said - I'll take a look at the wp-config file to avoid this in the future.

    Cheers.

  4. trijammer
    Member
    Posted 2 years ago #

    Sorry, should've re-marked as resolved. Done.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic