WordPress.org

Ready to get started?Download WordPress

Forums

SEO Ultimate
[resolved] All Links in Posts and Pages Are Showing as NoFollow (9 posts)

  1. melissaaggie98@gmail.com
    Member
    Posted 2 years ago #

    I've been using SEO Ultimate for a while now and haven't changed any of my settings, but since the new update, I'm noticing that all of my links in my blog posts and on my pages are showing as "nofollow" even though I don't have anything selected to do so in either the individual post or page settings or globally through the plugin.

    When using SEO4FireFox plugin, all of these external links in my posts and pages are showing as "nofollow", much to the chagrin of my sponsors. Is there any way this can fixed very soon? Thanks so much for your help with this.

    http://wordpress.org/extend/plugins/seo-ultimate/

  2. melissaaggie98@gmail.com
    Member
    Posted 2 years ago #

    I just wanted to update this with some further testing I've done. I went through and unchecked everything in the NoFollow Manager as well as made sure that no categories, tags or posts themselves were set to nofollow in the meta robot tags sections. I then tested again and all links in both posts and pages were showing as nofollow. The only links I noticed that were dofollow were the ones that were internal, thanks to the Deeplink Juggernaut and the plugins Yoast Breadcrumbs and Related Posts.

    Of course, I was using SEO4FireFox add-on to investigate this, so I guess there's always the possibility that the error lies in this add-on.

  3. melissaaggie98@gmail.com
    Member
    Posted 2 years ago #

    Hello,

    Just wanted to post an update for the last bit of testing I did to try and troubleshoot why the nofollow posts and there must be some trouble with the Nofollow Manager Module in the SEO Ultimate plugin. When I unchecked all of the options I previously had checked in the Nofollow Manager, I was still getting the error of posts being set to nofollow when they shouldn't have been. Once I disabled the Nofollow Module completely, the posts displayed with dofollow links as they should have all along. Unfortunately though, all of my comments and site's internal links are also showing dofollow since the module had to be disabled. Please send a fix along when you can. Thanks!

  4. John Lamansky
    Member
    Plugin Contributor

    Posted 2 years ago #

    What does SEO4Firefox show when all plugins are disabled?

  5. melissaaggie98@gmail.com
    Member
    Posted 2 years ago #

    When a link is nofollow in SEO4Firefox, the link is highlighted in red. You can customize these settings if you like, but I'm pretty sure red highlighting is the default.

    I just installed the new update hoping that the nofollow issues I've been experiencing might have been fixed, but I'm still seeing the same thing. When I have the nofollow module enabled even with all of the options unchecked, all of my posts' links are automatically nofollow. When I disable the nofollow module, all post links return to dofollow except the links I've labeled rel="nofollow" by hand.

    Also, I noticed that in the new update, the link masks didn't seem to be working in making the link nofollow. For instance, I had one post with both links changed using the linkmask generator on the post itself, yet they were still showing as dofollow links.

    Thanks so much for looking into this for me. I really appreciate it and think you have a wonderful SEO plugin.

  6. nikolajb
    Member
    Posted 2 years ago #

    Hi

    I have the same problem. Love SEO Ultimate - but this is really cracking me up.

    All links I place manually (without) then turns out as no-follow. I tried to create internal & external links using hardcoding in the html code, or using an existing post/page. In the HTML editor it all looks good, but when I check the site, then all links automatically turns out to be no-follow. Regardless if it an internal link or external.

    Only the automated links show up as do follow. Once I disable SEO Ultimate it's all good again, but I would not like to loose my favourite Plugin.

    Any suggestions on what to do

    Bonus Info: I haven't enabled no-follow in any of the settings, and been crawling through the application quite long now. You can se the problem at the buttom of my insurance site called i-forsikring here (All the bold links in bottom of the post)

  7. allanmcbilly
    Member
    Posted 1 year ago #

    This is 2 months old but I hope this helps:

    if you are seeing all your internal and external links nofollowed, go to link mask generator > settings and UNCHECK the "Nofollow aliased links"

    The thing is SEO Ultimate will interpret as an aliased link any link that you have on your post REGARDLESS of the fact if you have indeed used an alias or not.

    I'm quite disappointed by this specially coming from a "SEO" company.

    One thing tough: I've SEO ultimate installed and updated to the latest version on multiple sites: some show that options while other do not.

    Dunno why but that is how it is.

  8. melissaaggie98@gmail.com
    Member
    Posted 1 year ago #

    Thanks so much for the heads-up AllanMcBilly. The only way I got everything to work right is to complete disable the NoFollow Manager module and then use the WP Nofollow Post plugin in its place.

    I actually like this plugin more than the NoFollow portion of SEO Ultimate because it allows for greater global control of what you want to dofollow and what you don't. I guess that's another temporary fix until SEO Ultimate finally fixes this module.

  9. John Lamansky
    Member
    Plugin Contributor

    Posted 1 year ago #

    Thanks for reporting the problem. This is fixed in version 7.2.2.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic