WordPress.org

Ready to get started?Download WordPress

Forums

SEO Smart Links
Fix for Case-Insensitive "Ignore Words" Bug (1 post)

  1. crowinck
    Member
    Posted 2 years ago #

    If you have the plugin set to be case insensitive and are wondering why the "Ignore Keywords" setting isn't working, this could be your answer.

    Basically, the plugin compares the ignore keywords to the names of your posts or categories links are going to - not the text that's being linked, and it's still case sensitive even when it's set not to be. So if your post title is Hello World and you don't want to the plugin to link where you've written "hello world" in a post, your need to tell it to ignore "Hello World" not "hello world."

    You can fix this problem in the code by adding this code between line 104 and 105:

    if(!$options['casesens']){
        $arrignore=array_map('strtolower',$arrignore);
    }

    it should be right after:

    $arrignore=$this->explode_trim(",", ($options['ignore']));

    http://wordpress.org/extend/plugins/seo-automatic-links/

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.