WordPress.org

Ready to get started?Download WordPress

Forums

SEO Smart Links
does not work with href=#target (2 posts)

  1. CMCarlin
    Member
    Posted 3 years ago #

    I tried building some normal links to other content on same page using
    <a href="#target">Target</a> and then <a name="target"></a>

    and because of this plugin, the link always opens up in a new window.

    Great plugin, other than this.....

  2. Tevya
    Member
    Posted 3 years ago #

    I had the same problem, it doesn't let you override those settings in the actual content. I just disabled the target and nofollow options in this plugin, and installed External Links: http://wordpress.org/extend/plugins/sem-external-links/

    It allows you to override both the target and follow/nofollow settings in the code (if it sees either of those in your code, it won't add its own). It's one more plugin, but at least it works correctly. Also, it will apply its settings to the sidebar, etc, not just page/post content, which I think is very helpful (no more hard-coding new windows).

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic