WordPress.org

Ready to get started?Download WordPress

Forums

Send From
[resolved] still using www-data@alvazan.com as my from email :( (10 posts)

  1. deanhiller
    Member
    Posted 2 years ago #

    For some reason, mine is still sending postfix a from address of www-data which is the user apache2 is run under even after I change the email in the plugin :(.

    http://wordpress.org/extend/plugins/send-from/

  2. Benjamin Buddle
    Member
    Plugin Author

    Posted 2 years ago #

    Is the email address you're trying to use an account that's setup on the server? If not the plugin will not redirect properly.

    For example: If I want to send from noreply@mahoskye.com, if I do not have the account setup, emails will be sent from name@hostmonster.com. After the account is setup, emails will be sent from noreplay@mahoskye.com.

    I hope this helps.

  3. viktor.ilijasic
    Member
    Posted 1 year ago #

    This restriction makes no sense.

    My domain has mail hosted on another provider.

    What does local account have to do with "From:" field?

    Regards,
    Viktor

  4. viktor.ilijasic
    Member
    Posted 1 year ago #

    One tiny detail.

    After I created my From: account locally on my hosting provider, Send From completely stopped sending mails.

    :(

  5. Benjamin Buddle
    Member
    Plugin Author

    Posted 1 year ago #

    When I originally developed the plugin, either WordPress, or Hostmonster (my hosting provider), prevented me from sending email from addresses that were not set up and local. No matter what I tested, if the account was not setup locally I would always see emails, from the server, coming from an @host.hostmonster.com address. On a whim, on two separate servers (different hosting companies), I tested sending from various email addresses including ones locally setup, ones not setup but using the same domain, my personal gmail address, an address on a remote domain I don't own and didn't check to see if it exists, and finally a random string of text. Only on the last did I encounter any issues, and that was only to show the email coming form that Hostmonster account.

    I guess that restriction no longer exists.

    As to why you would no longer receive emails after having the account set up... I'm at a loss. There's no reason I can think of why a local account would prevent emails being sent.

  6. viktor.ilijasic
    Member
    Posted 1 year ago #

    I have to correct myself.

    After I set up the account locally, only plugin's "Send Test" stopped working.

    On further inspection I found that mails from wordpress started coming from the mail address I configured.

    So, thumbs up, plugin still works with this tweak. :)

    Thanks!

    Viktor

  7. viktor.ilijasic
    Member
    Posted 1 year ago #

    Well, plugin's main function still works, that is. Only test fails for some reason.

    Thank you for your quick response! :)

    Viktor

  8. Benjamin Buddle
    Member
    Plugin Author

    Posted 1 year ago #

    Oh, I think I was noticing that earlier. I was having trouble going directly into the plugin page and sending a test. I had to update options first and then it would allow me to send tests.

    I've known the options page has needed an update for a little while now, but I just haven't had the time to do so.

    I'm glad to hear it's working for you otherwise. ^_^

  9. viktor.ilijasic
    Member
    Posted 1 year ago #

    Confirmed. I just pressed Update Options (without actually changing anything) and test started working again. :)

    Thanks for the great plugin. ;)

    Viktor

  10. Benjamin Buddle
    Member
    Plugin Author

    Posted 1 year ago #

    Excellent.

    Thank you!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags