WordPress.org

Ready to get started?Download WordPress

Forums

Select Featured Posts
Check box not showing up on custom post types (5 posts)

  1. wpeck
    Member
    Posted 3 years ago #

    This plugin is exactly what I am looking for, but the check boxes to add a post to the featured list are not showing up in my custom post type. The column title appears in the admin screen, but no check boxes.

    Regular post types display the check box as long as I have a category assigned, and the widget works perfectly for checked posts. I have the same categories assigned for the custom post types where the option to set as featured does not appear.

    Any suggestions would be much appreciated.

    http://wordpress.org/extend/plugins/select-featured-posts/

  2. Kapil Chugh
    Member
    Plugin Contributor

    Posted 3 years ago #

    Thanks for your feedback.You are right.

    Support for custom post type is not there.I'll add it very soon.

  3. wpeck
    Member
    Posted 3 years ago #

    Thank you very much for getting back to me. I am never sure if I am doing something wrong, or if I am expecting something that is not possible.

    I'll watch for it -- maybe you can even drop a note to this thread when it is ready. It's exactly what I am looking for, but I almost always have a custom post type for my most important content. Thanks again. Great plugin.

  4. Twansparant
    Member
    Posted 2 years ago #

    Hi Kapil Chugh!
    Great plugin indeed, but I have the same wish/request as wpeck. Any updates on this?
    Thanks!

  5. Twansparant
    Member
    Posted 2 years ago #

    Hi wpeck,

    I'm trying to achive the same thing. I want to use this function on custom post types too. I got a bit further, the checkboxes are showing up now on custom post types;

    On line 74 in select_featured_posts.php comment the post_type part:
    if ($post->post_status == 'publish' && $post->post_password == '' /* && $post->post_type == 'post'*/ ) {

    However, the custom post type won't show up in the loop... Where do I need to change anything else in order to make this work?

    Thanks for any help!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic