WordPress.org

Ready to get started?Download WordPress

Forums

Secure Invites
Email address link not URL encoded (10 posts)

  1. Nyhm
    Member
    Posted 2 years ago #

    In Secure Invites v1.2.2, the invitation link includes the invited email address in the URL, like this:

    http://example.com/wp-login.php?action=register&email=name@domain.com

    The @ symbol is not URL encoded, and ends up being stripped out of the URL by WordPress.

    http://wordpress.org/extend/plugins/wordpress-mu-secure-invites/

  2. Chris Taylor
    Member
    Plugin Author

    Posted 2 years ago #

    I've just tried it with the latest version and the @ is OK for me. Is there something different about your WordPress installation that is encoding outgoing emails? I've not had any reports of this bug from anyone else.

  3. Nyhm
    Member
    Posted 2 years ago #

    The problem might be because I'm using WordPress HTTPS plugin. Your email is sent explicitly to "http" but the plugin is then redirecting to the same URL but "https". I notice that the @ symbol is stripped upon redirect (maybe WP being careful about URL encoding).

    I can fix this by hacking your code to always use an HTTPS URL (then it works fine with the @), but that won't survive an update.

    Another solution is to URL encode the email address (becomes something like: test%40example.com), which seems to work fine and survives any WP redirect.

    Thanks for looking into this. I hope it helps make your plugin more robust. This is a very compelling invite system.

  4. Chris Taylor
    Member
    Plugin Author

    Posted 2 years ago #

    If you use custom settings (/wp-admin/options-general.php?page=secure_invite_list&view=settings) you can choose the URL of the signup page, which is what is sent in the invitation email to the invited person. You can set HTTPS in there without hacking the plugin.

  5. Nyhm
    Member
    Posted 2 years ago #

    That's a good point, now that https is honored in the settings.

  6. pupix20
    Member
    Posted 2 years ago #

    Hi, I'm trying to use the plugin, and I have this problem.
    The invitation mail come with this URL
    http://www.linkedwines.com/wp-login.php?action=register&email=acosentino@atbk.com.ar

    When I enter the link the page goes to the message:
    Sorry, you must be invited to join this community.

    In my settings I have
    Membership Anyone can register , checked.

    Can you help me with this?
    Thanks

  7. Chris Taylor
    Member
    Plugin Author

    Posted 2 years ago #

    The actual signup page for your site is located at http://www.linkedwines.com/register-2/. Therefore this link works: http://www.linkedwines.com/register-2/?email=acosentino@atbk.com.ar

    Make sure the correct URL for your signup page is in our settings.

  8. pupix20
    Member
    Posted 2 years ago #

    Thanks for your reply. I do that, and now it works if I select
    "Anyone can join with or without an invitation, and all users can invite as many people as they like" but not with the others options. With the other options I get the message: "Sorry, you must be invited to join this community." Do you know what is my problem?

  9. Nio
    Member
    Posted 2 years ago #

    I have the same problem...

    When I choose first option in settings:
    1. "Anyone can join with or without an invitation, and all users can invite as many people as they like"
    >>> registration/invitation works!

    But when I choose the second option:
    2. "Signup is just for invited people, and all users can invite as many people as they like"
    >>> I get "Sorry, you must be invited to join this community."

    I try also the last option "Use custom settings"... same message/error!

  10. fredy666
    Member
    Posted 2 years ago #

    The same for me, the only solution is create a code for the people and put this in the email.

    The tempraly web is: http://s389000320.mialojamiento.es

    Thanks

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic