WordPress.org

Ready to get started?Download WordPress

Forums

Section Widget
has_cap was called with an argument that is deprecated since version 2.0! (1 post)

  1. jones7
    Member
    Posted 2 years ago #

    Hi

    I have installed the plugin but I am receiving this error message.

    Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /mnt/sites/unsaved.stcdev.com/current/wp-includes/functions.php on line 3551

    Please can you advise what I need to change.

    New to WordPress but I understand a little php!!

    Line 3551 points to this function

    function _deprecated_argument( $function, $version, $message = null ) {
    
    	do_action( 'deprecated_argument_run', $function, $message, $version );
    
    	// Allow plugin to filter the output error trigger
    	if ( WP_DEBUG && apply_filters( 'deprecated_argument_trigger_error', true ) ) {
    		if ( ! is_null( $message ) )
    			trigger_error( sprintf( __('%1$s was called with an argument that is <strong>deprecated</strong> since version %2$s! %3$s'), $function, $version, $message ) );
    		else
    			trigger_error( sprintf( __('%1$s was called with an argument that is <strong>deprecated</strong> since version %2$s with no alternative available.'), $function, $version ) );
    	}
    }

    Thx

    http://wordpress.org/extend/plugins/section-widget/

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic