WordPress.org

Ready to get started?Download WordPress

Forums

Secondary HTML Content
[resolved] No editor media buttons (or html button) on existing pages (8 posts)

  1. alan138
    Member
    Posted 3 years ago #

    Hey,

    I get the media buttons and the html button when I select to create a new page, but not when I edit a new page.

    It looks like the 'load-page.php' action is no longer being fired.

    To fix:

    In
    secondary_html_content.php

    Find on line 46:
    add_action('load-page-new.php','secondary_content_page_editor');
    add_action('load-page.php','secondary_content_page_editor');

    Replace with:
    add_action('load-post-new.php','secondary_content_page_editor');
    add_action('load-post.php','secondary_content_page_editor');

    http://wordpress.org/extend/plugins/secondary-html-content/

  2. bt-chadski
    Member
    Posted 3 years ago #

    Thank you, this worked for me.

  3. Jeff Byrnes
    Member
    Posted 3 years ago #

    This needs to be rolled back into the plugin; fixed this issue for me as well!

  4. ocwramsay
    Member
    Posted 3 years ago #

    Works great, except when inserting image into a secondary html area the image appears in the original top content panel...

    Anyone else get this or found a way to insert image in corrent panel?

  5. dibidi
    Member
    Posted 3 years ago #

    This fix worked great. This is the first time I'm using this plugin. It's a great plugin but the ability to add html and media after creating a page/post is important.

  6. admin8ter
    Member
    Posted 3 years ago #

    Having the same problem. I will try this. Thank you.

  7. admin8ter
    Member
    Posted 3 years ago #

    Yes this worked for me too!
    He should put this in an update patch and announce it?

  8. Eric Marden
    Member
    Posted 3 years ago #

    I hope the author fixes this in the next release.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic