WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Search API] Plugin could not be activated because it triggered a fatal error (9 posts)

  1. SauloB
    Member
    Posted 5 years ago #

    Installed, activated the plugin and got this error:

    Fatal error: Cannot redeclare load_search() (previously declared in /var/www/avwordpress/wp-content/plugins/search/search.php:594) in /var/www/avwordpress/wp-content/plugins/search/search.php on line 598
    
    Warning: Unknown: open(/var/lib/php/session/sess_l9u3mnhoomqhqm6fmalg0v6gq4, O_RDWR) failed: Permission denied (13) in Unknown on line 0
    
    Warning: Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct (/var/lib/php/session) in Unknown on line 0

    Btw, I got this message too:

    The search system is almost ready. You must enable a search plugin to work with the Search API plugin.

    Where do I enable it? Where can I configure this plugin?

    http://wordpress.org/extend/plugins/search/

  2. amygail67
    Member
    Posted 5 years ago #

    as far as
    "The search system is almost ready. You must enable a search plugin to work with the Search API plugin."

    Read the installation notes. There's an explanation there

  3. SauloB
    Member
    Posted 5 years ago #

    Thanks amygail67. Found it. Done it.

    But, I got the same Fatal Error for both plugins. It didn't work for me.

  4. Justin Shreve
    Member
    Posted 5 years ago #

    Hi,

    I've had this reported by one other user. (the fatal error part) I've been unable to reproduce it this far.

    Could you answer the following questions in the similar bug report?

    http://code.google.com/p/wpsearchapi/issues/detail?id=5

    Can you give me the exact versions of PHP, MySQL, WordPress etc?
    Can you give me the exact steps?
    ie:

    1) Uploaded search/ directory
    2) Activated Search API (which then activated MySQL)

    Have you had a previous version installed?
    Are you installing this on the latest version?

    Thanks for taking the time to post about this. Hopefully I can have a fix to you soon.

    -Justin Shreve

  5. SauloB
    Member
    Posted 5 years ago #

    I just download the new version and it's fixed. I was able to activate the plugin and the MySQL engine.

    But, there's no result for me on every search I tried. No result at all.

    I didn't try the Google Engine.

    Thanks.

  6. Justin Shreve
    Member
    Posted 5 years ago #

    Did you uninstall the plugin and reinstall from scratch? (Deactivate the plugins and click delete under search api then reupload and activate)

    Something may have not installed during the fatal error.

  7. f1mktsol
    Member
    Posted 5 years ago #

    So...I do not see this in admim anywhere. In other words, there is no way to customize this? Hmmm.

  8. Justin Shreve
    Member
    Posted 5 years ago #

    It depends.

    The Google plugin does contain an admin control panel for editing a few of the required settings.

    The MySQL plugin does not as it wasn't part of the original scope of the GSoC project. More customization is slated for a later release :).

  9. biramax
    Member
    Posted 4 years ago #

    The new version didn't resolve the problem. I still have these fatal errors when activating Search API and then MySQL plugin.
    I've deactivated previous plugin version, deleted it from plugin page, uploaded new version and activated.
    WP 2.8.3
    PHP 5.2.5

Topic Closed

This topic has been closed to new replies.

About this Topic