WordPress.org

Ready to get started?Download WordPress

Forums

RVSubMenu
Widget Not Appearing (3 posts)

  1. mrwweb
    Member
    Posted 2 years ago #

    Maybe I'm missing something obvious, but I don't see the submenu widget anywhere.

    I have one menu.
    I've set the widget to use that menu.
    I've confirmed that a text widget in the same sidebar appears just fine.
    Settings:
    Menu: Primary (twenty ten theme location, also tried unsetting this)
    Start Level: tried 0 and 1
    Show submenus: tried both
    Depth: 0
    I resaved both my menu and theme location.
    WP_Debug is set to true and I see no errors.
    I'm using a very simply Twenty Ten child theme.
    WordPress Importer is the only active plugin.

    Any ideas???

    http://wordpress.org/extend/plugins/rv-submenus/

  2. wido
    Member
    Posted 1 year ago #

    I had the same issue and I resolved it by deleting
    add_action( 'wp_update_nav_menu_item', array(&$this, 'add_nivel_menu_item'), 10, 3);
    add_filter( 'wp_nav_menu_objects', array(&$this, 'get_current_nav_menu') );

    and commenting line: 90 //if(!$this->currentMenu) return;in wordpress 3.5.1.

    I'm not practice with wp nav menu objects but seem there are some wrong assignments in get_current_nav_menu function.

  3. wido
    Member
    Posted 1 year ago #

    Sorry, after some tests I see that plugin works only if level is set to 2. If the level is set to 3 nothing appear.I tried with six item levels, but nothing change.

    Finally i changed the $current_element_markers = array('current-menu-ancestor' ); with 'current-menu-parent' and now i can set level 2,3,4 etc... but i'm confused about start level. In my case if I'm into the menu level 5 and the start level is set to 4 I can't see the nav menu items.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic