WordPress.org

Ready to get started?Download WordPress

Forums

RSSImport
[resolved] Function hardcoded to author's URL/shortcodes not working? (7 posts)

  1. bws-online
    Member
    Posted 1 year ago #

    I'm using shortcodes to pull in a blog's feed, and without going in to edit rssimport.php it's not pulling the correct feed (even though I have the proper shortcode).

    In rssimport.php, in function RSSImport_Shortcode, it has 'feedurl' hardcoded to the author's feed (on a .de website).

    Is there somewhere else to make an adjustment, or do you HAVE to edit rssimport.php for this to work? (If you have to edit rssimport.php, that's not ideal for future updates....)

    http://wordpress.org/extend/plugins/rss-import/

  2. Frank
    Member
    Plugin Author

    Posted 1 year ago #

    The value is not harcoded, is only the default value and was replaced, if you set an new url in the param feedurl inside the shortcode, like [RSSImport display="5" feedurl="http://example.com/feed/"]

  3. bws-online
    Member
    Posted 1 year ago #

    Okay, well if it's not hardcoded, then it's not working for shortcodes. I did as you described, and it still showed the default value.

  4. Frank
    Member
    Plugin Author

    Posted 1 year ago #

    Works fine; see this page: http://kvfl.com/kletternews/
    This is a page in WP and use lot of shortcodes with different feed urls, like

    <h2>Deutsch sprachige News:</h2>
    <h3>KVFL.com [<a href="http://kvfl.com/feed/" title="Link zum RSSFeed">RSS</a>]</h3>
    [RSSImport feedurl="http://kvfl.com/feed/"]
  5. rpvp
    Member
    Posted 1 year ago #

    No, it does not. Even changing the feed url you still get the Bultge feed.
    I'm using this shortcode:

    [RSSImport display="3" feedurl="http://www.mydesert.com/apps/pbcs.dll/section?category=RSS06&template=rss_gd_re"
    displaydescriptions="true" html="false"
    start_items="

      " end_items="
    " paging="true" ]

    And still getting the german feed.

  6. pixelgeek
    Member
    Posted 1 year ago #

    I am having the same issue. Providing a feed url property does not change the RSS feed that is being returned. I still get the feed from the developers site.

  7. pixelgeek
    Member
    Posted 1 year ago #

    I just got mine to work. I suspect that you might have the same issue that I did. It appears that when I copied the example code from the plugin page that some non-standard characters were inserted as spaces. I deleted all the spaces between the entries and then added proper spaces and it solved the problem.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.