WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: RSSImport] eBay RSS Feed Gives Error or Not Valid (2 posts)

  1. hikertron
    Member
    Posted 4 years ago #

    Hi,

    This seems like a great plugin but I can't seem to get it to work. I'm trying to use the short code on page (not sidebar) to display an eBay affiliate RSS feed which I've checked as valid. See report notes at bottom.

    Using simplepie "on" (true) it will display in the sidebar (not desired but shows it will display) but simplepie on or off it won't display on page.

    Here is the error:

    Error: Feed has a error or is not valid

    Version 4.4.6 of the plugin.

    I've even stripped it down for troubleshooting to just this code but it won't work:

    [RSSImport feedurl="http://thefeedurlfromebay" use_simplepie="TRUE"]

    Note please I've tried it with a , after the " following the url and without - neither works and I can't find a document that makes clear if it is needed there or not.

    Thank you!

    feedvalidator.org Report

    This is a valid RSS feed.

    Recommendations

    This feed is valid, but interoperability with the widest range of feed readers could be improved by implementing the following recommendations.

    *

    line 1, column 39: Use of unknown namespace: urn:ebay:apis:eBLBaseComponents (330 occurrences) [help]

    <?xml version="1.0" encoding="UTF-8" ?><rss version="2.0" xmlns:cf="http://w ...
    ^

    *

    line 18, column 67: title should not contain HTML: ( (4 occurrences) [help]

    <title><![CDATA[(TDI, Diesel) (Category: Jetta )]]></title>
    ^

    *

    line 21, column 73: description should not contain HTML: ( (4 occurrences) [help]

    <description><![CDATA[(TDI, Diesel) (Category: Jetta )]]></d ...
    ^

    *

    line 27, column 67: title should not contain HTML: ( (4 occurrences) [help]

    <title><![CDATA[(TDI, Diesel) (Category: Jetta )]]></title>
    ^

    *

    line 808, column 0: Missing atom:link with rel="self" [help]

    </channel>

    http://wordpress.org/extend/plugins/rss-import/

  2. Frank
    Member
    Posted 4 years ago #

    please activate the debug-function of the plugin; maybe it is a problem after read the rss. also change the library to SimplePie, is better with complex feeds. It give a parameter for simplepie and debug-mode.

Topic Closed

This topic has been closed to new replies.

About this Topic