WordPress.org

Ready to get started?Download WordPress

Forums

RSS Image Feed
[resolved] Posts without images or posts with images after a page break are showing er (3 posts)

  1. melissaaggie98@gmail.com
    Member
    Posted 2 years ago #

    I have been using this plugin for a while, but lately I am disappointed because my feed is showing four lines of error code instead of images or nothing at all.

    For instance, if I have a post that contains an image after the page break, I receive the following in my feed:

    Warning: Division by zero in /home/livmommy/public_html/wp-content/plugins/rss-image-feed/image-rss.php on line 221

    Warning: Division by zero in /home/livmommy/public_html/wp-content/plugins/rss-image-feed/image-rss.php on line 231

    Warning: Division by zero in /home/livmommy/public_html/wp-content/plugins/rss-image-feed/image-rss.php on line 221

    Warning: Division by zero in /home/livmommy/public_html/wp-content/plugins/rss-image-feed/image-rss.php on line 231

    If a post doesn't contain an image, then in my opinion, there should be a default image, such as the site's logo, that shows up in the feed instead. At worse, the feed should only show text without an image. I also don't understand why I get this error when there is an image in the post, it's just after the page break. Can you please help to correct this right away? I do not like this code showing up in my feed. Thanks!

    http://www.mommylivingthelifeofriley.com
    http://feeds.feedburner.com/mommylivingthelifeofriley/wp

    http://wordpress.org/extend/plugins/rss-image-feed/

  2. tepelstreel
    Member
    Plugin Author

    Posted 2 years ago #

    Well, neither do I. If there is no image, only text will show up; why some people get these errors, I cannot say, because I never get them. Thanks a lot for the hint with the pagebreak.

    Perhaps that brings me further with my search for the reason of these strange happenings.

  3. tepelstreel
    Member
    Plugin Author

    Posted 2 years ago #

    Should be solved with the new version.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic