WordPress.org

Ready to get started?Download WordPress

Forums

Role Scoper
[resolved] No access at all (9 posts)

  1. MyrddinDE
    Member
    Posted 3 years ago #

    Hello,

    I just upgraded an existing version from 1.2.xx to the latest version. After uploading the plugin I had no longer access to the site, even logging in as admin or alternate user with admin rights.
    Removing the directory did not help either, as did installing the old version of the file.
    I don't have access to phpmyadmin or any similar tool to clear the tables, what do I do to get access to the site? Displaying it still works.
    Was supposed to upgrade plugins and I had a hunch that it wasn't the best idea to upgrade this :D

    kind regards,

    Michael

  2. MyrddinDE
    Member
    Posted 3 years ago #

    Did a drop table per php, where gggg_ is a substitute of my $table_prefix.

    "DROP TABLE gggg_role_scope_rs";
    "DROP TABLE gggg_user2role2object_rs";
    "DROP TABLE gggg_user2group_rs";
    "DROP TABLE gggg_groups_rs";
    -> success message, second run of the .php showed a "no such table exists error"

    And then the folder has been removed, I still have no access to the site.
    http://domain.tld/wp-admin/ -> "Du har ikke nok rettigheter til å få tilgang til denne siden." -> "You do not have enough privileges to access this page."

  3. kevinB
    Member
    Plugin Author

    Posted 3 years ago #

    Can you post the contents of your .htaccess and wp-content/uploads/.htaccess files?

  4. MyrddinDE
    Member
    Posted 3 years ago #

    I do not really hve access to .htaccess files. They are hidden on FTP, was just able to display the files with a php file manager I have uploaded to the site.

    /www/html/wp-content/uploads/.htaccess is nonexistant

    /www/html/.htaccess

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    
    # BEGIN WPSuperCache
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    AddDefaultCharset UTF-8
    RewriteCond %{REQUEST_URI} !^.*[^/]$
    RewriteCond %{REQUEST_URI} !^.*//.*$
    RewriteCond %{REQUEST_METHOD} !POST
    RewriteCond %{QUERY_STRING} !.*=.*
    RewriteCond %{HTTP:Cookie} !^.*(comment_author_|wordpress|wp-postpass_).*$
    RewriteCond %{HTTP_USER_AGENT} !^.*(2.0\ MMP|240x320|400X240|AvantGo|BlackBerry|Blazer|Cellphone|Danger|DoCoMo|Elaine/3.0|EudoraWeb|Googlebot-Mobile|hiptop|IEMobile|KYOCERA/WX310K|LG/U990|MIDP-2.|MMEF20|MOT-V|NetFront|Newt|Nintendo\ Wii|Nitro|Nokia|Opera\ Mini|Palm|PlayStation\ Portable|portalmmm|Proxinet|ProxiNet|SHARP-TQ-GX10|SHG-i900|Small|SonyEricsson|Symbian\ OS|SymbianOS|TS21i-10|UP.Browser|UP.Link|webOS|Windows\ CE|WinWAP|YahooSeeker/M1A1-R2D2|iPhone|iPod|Android|BlackBerry9530|LG-TU915\ Obigo|LGE\ VX|webOS|Nokia5800).*
    RewriteCond %{HTTP:Accept-Encoding} gzip
    RewriteCond %{DOCUMENT_ROOT}/wp-content/cache/supercache/%{HTTP_HOST}/$1/index.html.gz -f
    RewriteRule ^(.*) /wp-content/cache/supercache/%{HTTP_HOST}/$1/index.html.gz [L]
    
    RewriteCond %{REQUEST_URI} !^.*[^/]$
    RewriteCond %{REQUEST_URI} !^.*//.*$
    RewriteCond %{REQUEST_METHOD} !POST
    RewriteCond %{QUERY_STRING} !.*=.*
    RewriteCond %{HTTP:Cookie} !^.*(comment_author_|wordpress|wp-postpass_).*$
    RewriteCond %{HTTP_USER_AGENT} !^.*(2.0\ MMP|240x320|400X240|AvantGo|BlackBerry|Blazer|Cellphone|Danger|DoCoMo|Elaine/3.0|EudoraWeb|Googlebot-Mobile|hiptop|IEMobile|KYOCERA/WX310K|LG/U990|MIDP-2.|MMEF20|MOT-V|NetFront|Newt|Nintendo\ Wii|Nitro|Nokia|Opera\ Mini|Palm|PlayStation\ Portable|portalmmm|Proxinet|ProxiNet|SHARP-TQ-GX10|SHG-i900|Small|SonyEricsson|Symbian\ OS|SymbianOS|TS21i-10|UP.Browser|UP.Link|webOS|Windows\ CE|WinWAP|YahooSeeker/M1A1-R2D2|iPhone|iPod|Android|BlackBerry9530|LG-TU915\ Obigo|LGE\ VX|webOS|Nokia5800).*
    RewriteCond %{DOCUMENT_ROOT}/wp-content/cache/supercache/%{HTTP_HOST}/$1/index.html -f
    RewriteRule ^(.*) /wp-content/cache/supercache/%{HTTP_HOST}/$1/index.html [L]
    </IfModule>
    
    # END WPSuperCache
    
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
  5. kevinB
    Member
    Plugin Author

    Posted 3 years ago #

    Those .htaccess contents are corrupted. Try changing it to:

    [Code moderated as per the Forum Rules. Please use the pastebin]

  6. MyrddinDE
    Member
    Posted 3 years ago #

    still no access

    .htaccess

    removed the super cache directory

    tried to reload, shift reload, clear browser cache, different browser, no success

  7. kevinB
    Member
    Plugin Author

    Posted 3 years ago #

    Please open a new ticket on my dedicated Role Scoper support forum.

  8. MyrddinDE
    Member
    Posted 3 years ago #

    Here 2 more screenshots,

    1) this is what is being displayed right after logging on: no dashboard
    2) and here a list of tables: tables in miniadmind. As you can see the role scoper tables are gone

  9. kevinB
    Member
    Plugin Author

    Posted 3 years ago #

    Your WP administrator access came back after I disabled the WP Native Dashboard plugin by renaming its folder.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic