WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Robots Meta] probs with robots meta plugin and wp 2.6 (13 posts)

  1. Ovidiu
    Member
    Posted 6 years ago #

    got trouble activating this plugin:

    Warning: unserialize() expects parameter 1 to be string, array given in /var/www/web46/web/wp-content/plugins/robots-meta/robots-meta.php on line 630
    
    Warning: unserialize() expects parameter 1 to be string, array given in /var/www/web46/web/wp-content/plugins/robots-meta/robots-meta.php on line 613
    Array

    http://wordpress.org/extend/plugins/robots-meta/

  2. Anonymous
    Unregistered
    Posted 6 years ago #

    I'm using WP 2.6 and I have it activated - but it's not working. When I try to save a page with a specific set of meta tags (noindex,follow, for instance) ticked, it doesn't "keep".

    Maybe these are related - I was looking for a fix & came upon this.

  3. jrothe
    Member
    Posted 6 years ago #

    I just figured out today that this plugin was causing problems when I did a manage > posts > search. Any search I would do, or a filter, I would be redirected to the homepage of my website...

    Robots Meta doesn't work with WordPress 2.6

  4. specialburce
    Member
    Posted 5 years ago #

    yes it is not working on wp 2.6

  5. pixelhub
    Member
    Posted 5 years ago #

    Its working fine with 2.6.2, i have the same problem as rferrall

    When I try to save a page with a specific set of meta tags (noindex,follow, for instance) ticked, it doesn't "keep"

    the tags are added to the post/page but when in edit mode it does not remember what option was selected.

  6. Ovidiu
    Member
    Posted 5 years ago #

    no solution to this? seems very related to this problem: http://wordpress.org/support/topic/196162?replies=10

  7. Joost de Valk
    Member
    Posted 5 years ago #

    I just fixed this in version 3.0.11

  8. jamisonfitz
    Member
    Posted 5 years ago #

    This plugin while great and absolutely essential, caused me a lot of headache, i kept getting redirected from the admin side to the index of my blog, i disabling my htaccess files and i would still be redirected, that's when i disabled each plugin one by one until i found the problem which was this plugin, after i determined it was Robots Meta causing the problem i went through and enabled each settings one by one and found that the "Redirect search results pages when referrer is external" setting is what caused me to be redirected to the blog index from admin, i should note i am in fact running 3.0.11 and that the redirect only occurs when the admin url includes ?page= or something similar.

  9. Joost de Valk
    Member
    Posted 5 years ago #

    Ey Jamison, I'm gonna jack that feature out, it's incredibly annoying :)

  10. siotw
    Member
    Posted 5 years ago #

    For some reason your Robots Meta plugin is inserting 'noindex,nofollow' tags in the meta robots tag by default. I can't figure out why ... the theme that I'm utilizing for the blog does in fact have the <?php wp_head(); ?> in the header.php file.

    No matter what meta tag selection I make for the post or the page, it always ends up being 'noindex,nofollow' on each of the pages when I update it.

    I trolled the forum for ideas, but this has me stumped. I deleted the plugin and tried reinstalling it, but to no avail.

    Any suggestions?

  11. siotw
    Member
    Posted 5 years ago #

    The index page even has a 'noindex,nofollow' robots meta tag on it. What's up with that?

  12. siotw
    Member
    Posted 5 years ago #

    Just to make sure I wasn't going crazy, I checked my WP database and all of the Robot Meta tags on the individual posts and pages are set properly to 'index,follow' but when the page is delivered and renders the Robot Meta tags are all showing up as 'noindex,nofollow' on the page. This is the very definition of wonky. Would a small donation to Yoast be in order to make sure my home page, posts and pages aren't noindexed, nofollowed by this plugin? wow....

  13. zivnissim
    Member
    Posted 5 years ago #

    Ho SIOTW,
    The same problem of NO INDEX NO FOLLOW occured to me.
    It is because of a Simple reason -
    In admin/ settings / Privacy you checked "I would like to block search engines, but allow normal visitors" that is why you see at your source code (any page/post/category/idex etc.) - noindex nofollow .

    Just remember to check the second checkbox....

Topic Closed

This topic has been closed to new replies.

About this Topic