WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Robots Meta] Plugin does not work! (26 posts)

  1. Stendo
    Member
    Posted 4 years ago #

    Hey there!

    I was using the plugin and it worked fine! But now I've installed it on a claen WordPress site, but it does not work properly:

    When writing a post or page I want to put in "noindex,nofollow", but when I've updated the page, the option is stile "index,follow" and it did not put the meta-tags in the page...

    Can someone help me out please or tell me what went wrong?

    Thanks!

  2. Stendo
    Member
    Posted 4 years ago #

    Anyone? Please???

  3. cyboc
    Member
    Posted 4 years ago #

    I have the exact same problem. I select the "noindex, nofollow", save the page, then reload the page. Upon reloading the page, the setting is back to "index,follow". I'm using WordPress 2.8.4 and Robots Meta 3.2.2. Any suggestions?

  4. cyboc
    Member
    Posted 4 years ago #

    I should add that I have also have All in One SEO Pack 1.6.5 installed. Are the two plugins compatible?

  5. cyboc
    Member
    Posted 4 years ago #

    I disabled All In One SEO Pack and I still have the problem.

  6. cyboc
    Member
    Posted 4 years ago #

    Perhaps this problem is happening because I am using WordPress 2.8.4? Apparently Robots Meta 3.2.2 has only been tested up to WordPress 2.8.2...

  7. Tom H Brown
    Member
    Posted 4 years ago #

    Yep, same problem here. Every time I refresh a page after choosing "noindex nofollow" it refreshes with "index follow" -- I hope we hear from someone soon.

    Has anyone found a similar plugin we could try?

  8. vielmetter
    Member
    Posted 4 years ago #

    Hi guys, I'm having the same problem. I cannot seem to change the index,follow setting on a "per article" basis. Each time I update a post, the robots meta setting goes back to the default "index,follow". I'm running WordPress 2.8.1

  9. pepsirules2k
    Member
    Posted 4 years ago #

    I think I solved this problem. I have several WP blogs and one of them has been around for a year. I remember downloading meta robots 3.0.11 on one of those blogs a while back / while others got the plugin just recently. I have made successful changes at the time using WP 2.7 and was updating the plugin and WP installations. So, the moral of the story is: if you installed an older plugin, or exactly 3.0.11 in my case, you will be grandfathered in - even if you update to the latest MetaRobots plugin and WP installation.

    I tested this theory on a brand-spanking new blog. I couldn't make any changes - always reverting to index, follow. I uninstalled the new plugin, deleted it from the folder. Then, I copied and pasted the 3.0.11 via FTP and activated it. I made changes to the pages I wanted (Index, NOfollow) and etc. I upgraded the plugin to the latest version 3.2.2 (as of this writing) and it worked on a 2.8.4 WP install. I could even make changes to the new pages I have created.

    I hope this makes sense.

  10. Rick
    Member
    Posted 4 years ago #

    I was having the same problem with WordPress 2.8.4. However, I had an older version of Meta Robots on my computer 3.07) and I tried what pepsirules2k mentioned:

    • Delete your current Robots Meta installation
    • Upload an older Robots Meta plugin -- so far 3.0.11 and 3.0.7 work for this
    • Upload the older Robots Meta plugin to your WordPress plugins folder and activate it

    At this point, you can verify that the older plugin is working, and if it is -- upgrade (automatically is how I did it) to the newest version. This worked for me.

    I'm not sure where you can get outdated wordpress plugins, though -- I searched for a while online and then finally looked through one of my backup folders & found the older plugin.

    Also, a while ago I couldn't get Robots Meta to work, and I discovered that my theme didn't include wp_head call in the header. So, if the above doesn't work for you, be sure that this:

    <?php wp_head(); ?>

    is in your header.php file.

    Actually -- one more thing. Several themes that I've used lately have included the meta robots tag in the header.php file by default, and it always shows meta_robots=index,follow. You'll want to check the header.php to be sure that the meta robots tag isn't hard-coded into your theme's template.

  11. schoe
    Member
    Posted 4 years ago #

    Hi there,

    thank you pepsirules2k and rferrall for your hints.

    I also tried with Robots Meta 3.0.11 and automatic upgrade and it worked fine for me ... though it doesn't make sense to me really ...

    If anybody is still looking for the old versions he can find them at:

    WordPress > Robots Meta

  12. djsapphire
    Member
    Posted 4 years ago #

    I have the same problem too. The "index, follow" always becomes the default no matter what other option i choose on a page.

    Sigh, hope this gets fixed soon. It's ridiculous to have to install an older version of RM in order to get this to work.

  13. mwkgeo
    Member
    Posted 4 years ago #

    I couldn't make any changes - always reverting to index, follow. I uninstalled the new plugin, deleted it from the folder. Then, I copied and pasted the 3.0.11 via FTP and activated it. I made changes to the pages I wanted (Index, NOfollow) and etc. I upgraded the plugin to the latest version 3.2.2 (as of this writing) and it worked on a 2.8.4 WP install. I could even make changes to the new pages I have created.

    Yep - this workaround fixed the same issue for me as well. Thanks.

    I like this plugin because it is simple and doesn't have feature bloat - compared to many "SEO" plugins. I hope Joost will continue to develop robots meta and release a glitch-free version.

  14. Webstractions
    Member
    Posted 4 years ago #

    The problem was the omission of a function call which alters the post table by adding the 'robotsmeta' column. This column is needed to hold the values you select on a post/page by post/page basis.

    The fix is to find the following line of code in robots-meta.php:

    update_option('RobotsMeta', $options);

    And replace with the following:

    //update_option('RobotsMeta', $options);
    robotsmeta_update();

    The function robotsmeta_update() does a version check which makes the table alteration, as well as the call to WP function update_option().

  15. Webstractions
    Member
    Posted 4 years ago #

    The fix I posted previously will only add the new column if you choose to save settings in the plugin.

    Instead, add the call to the end of the plugin file and right before the ?>

    robotsmeta_update();

  16. Rhonda Johnson
    Member
    Posted 4 years ago #

    Thank You Webstractions!

    I was having the same problem as everyone above. I tried the fix of deleting and installing older versions. That didn't work for me no matter how many different older versions I tried. But your fix worked like a charm!

    Thanks so much.

    Awesome plug-in, once you get it to working.

  17. Sgroove
    Member
    Posted 4 years ago #

    Thanks Webstractions, your suggestion worked for me.

  18. markey101101
    Member
    Posted 4 years ago #

    Webstractions can you elaborate please? I'm confused

  19. markey101101
    Member
    Posted 4 years ago #

    Confused where you say add the update part to the end of the plugin if not updating?

    My understanding so far is to change the line of code in the plugin and press save. But don't know what to do with the update part.

    Thanks

  20. slimtee
    Member
    Posted 4 years ago #

    Hi everyone,

    Thanks to everyone who's posted solutions here...as a newbie they've been very useful to me.

    I've installed the plugin (using the older version workaround) and edited my settings however, when I check the source code for pages that have been set to 'index, nofollow' I see this bit of code: <meta name="robots" content="follow, all" />...is that correct keeping in mind the settings?

    I imagine the content would be set to display "nofollow"? But as I'm not a coder, what do I know (lol).

    If anyone can shed any light on this, I'd appreciate the help.

    Thanks in advance :-)

  21. markey101101
    Member
    Posted 4 years ago #

    There was a solution to it by installing the older version of the plugin then upgrading. That worked like a charm.

  22. Jo Landers
    Member
    Posted 4 years ago #

    Looking at the code, it appears robots-meta.php expects a field in wp_posts named robotsmeta (see line 59 of the code: $robotsmeta = $post->robotsmeta;).

    I added the field as a varchar length 32, and it now seems to work. Not thrilled about modifying the database (would have preferred the robots-meta.php file inserted into wp_postsmeta instead), but this did not require any changes to the plug-in code. The older versions of the plug-in probably took care of adding that field for you when you installed it...

  23. movingforward
    Member
    Posted 4 years ago #

    Thank you Webstractions, your fix worked brilliantly!
    For anyone else, just to clarify how the fix works:

    Open and edit your robots-meta.php file located under your plugins directory on web server.

    Add this extra line just before the ?> at the end of file.
    robotsmeta_update();

    Save and re-upload edited robots-meta.php file to web server, voila!

  24. marikamitsos
    Member
    Posted 4 years ago #

    Hi all, AND ATTENTION EVERYONE.
    I too face some issues with this wonderfull plugin. I installed version 3.2.5 on a 2.84 wordpress release for the first time and had:
    1. the same issue as stendo from 5 months ago. I solved it following pepsirules2k's workaround, by deleting, installing v3011 and then upgrading back to v325. It did save the settings to noindex/nofollow.

    BUT, BE WARNED
    2. I checked the content on the plugin's .htaccess box and was nothing like my already existing .htaccess file.
    So I reverted back to v3011 and everything works fine.

    This is a wonderfull plugin. Joost, could you please look into it? I mean it would be great to be able to upgrade to the latest version and enjoy all the benefits of your latest work. Thank you in advance.

  25. diecastfast
    Member
    Posted 3 years ago #

    Good grief! I just realized that what used to be my favorite plugin on over 440 WP installations is not even functional on any of them! None of the workarounds above work for me and I've checked all the theme calls. Is there no longer any support or development on this plugin?

  26. diecastfast
    Member
    Posted 3 years ago #

    Just found my solution: Platinum SEO Pack. Installed that and was able to uninstall Robots Meta (doesn't work anyway) and All-In-One SEO Pack.

Topic Closed

This topic has been closed to new replies.

About this Topic