WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Robots Meta] nofollow typo causes tags to be followed and indexed (12 posts)

  1. yacoub
    Member
    Posted 4 years ago #

    "Nofollow the links to your tag pages

    If you've decided to keep your tag pages from being indexed, you might as well stop throwing link-juice at them on each post..."

    This is actually broken if you look at the source of a post:

    Sample from mine:

    <div class="postmetabottom">
    
    <div class="tags">Tags: <a href="http://www.test.com/home/tag/action/" rel="nofollow tag">Action</a>,

    As you see, it actually puts rel="no follow tag" instead of putting rel="nofollow".

    This explains why all my tags are being indexed by Google despite my best efforts to prevent it.

    Hope to see this fixed.

    Thanks!

  2. yacoub
    Member
    Posted 4 years ago #

    Yoast: Any chance this will get fixed, if it is indeed a bug with Robots Meta?

  3. yacoub
    Member
    Posted 4 years ago #

    Hoping this bug will get fixed...

  4. yacoub
    Member
    Posted 4 years ago #

    It puts rel="nofollow tag" in the code instead of rel="nofollow".

  5. yacoub
    Member
    Posted 4 years ago #

    The new version of Robots Meta plugin still has this bug, so link juice loss and spider following through to your Tag pages still occurs.

  6. melstan1
    Member
    Posted 4 years ago #

    dude, you can access the code in the edit screen. Why don't you just fix it yourself? If you want to use the plugin and this is the only mistake, you can do it yourself and not wait on the developer.

  7. willard97
    Member
    Posted 4 years ago #

    dude, I tried editing the code and it still didn't work.

    From this:
    function nofollow_taglinks($output) {
    $output = str_replace('rel="tag"','rel="nofollow tag"',$output);
    return $output;

    To this:
    function nofollow_taglinks($output) {
    $output = str_replace('rel="nofollow"',$output);
    return $output;

    Didn't work.

  8. spotcream
    Member
    Posted 4 years ago #

    are you using any cache plugins ??

  9. willard97
    Member
    Posted 4 years ago #

    Yup, using WP Super Cache.

  10. spotcream
    Member
    Posted 4 years ago #

    disable the cache plugin then try as you might be viewing the cached file and not the real one...

  11. willard97
    Member
    Posted 4 years ago #

    Nope, still not working. Disabled Super Cache and retried.

    Even tried a new post to see if that would change anything.
    http://sellitontheweb.com/blog/

    Is the edited syntax above correct? Should that work?

  12. invasive
    Member
    Posted 4 years ago #

    I tried this, and it seemed to work:

    From this:
    function nofollow_taglinks($output) {
    $output = str_replace('rel="tag"','rel="nofollow tag"',$output);
    return $output;

    To this:
    function nofollow_taglinks($output) {
    $output = str_replace('rel="tag"','rel="nofollow"',$output);
    return $output;

    Remember that str_replace(a,b,c) will replace instances of "a" with "b" in string "c".

Topic Closed

This topic has been closed to new replies.

About this Topic