WordPress.org

Ready to get started?Download WordPress

Forums

Revisionary
not working with WPMU 3.1.3 (2 posts)

  1. James Revillini
    Member
    Posted 3 years ago #

    PROBLEM
    when an admin of a site clicks on the 'options' link for the plugin, it redirects to the dashboard of another blog!

    BACKGROUND
    I installed the plugin as the network admin but did not network activate.

    TO REPRODUCE
    1. log in as admin to whatever site has been created
    2. plugins > activate Revisionary
    3. click the 'options' link in the Revisionary plugin item

    EXPECTED
    It to go the Revisionary options panel (which is not on the admin menu anywhere, incidentally)

    WHAT HAPPENED
    It brought me to the dashboard of the first OTHER blog for which I am an admin. You read that correctly - it takes me out of the current site and to the dashboard of another. For example, I might be at

    http://domain.com/blogs/site-TWO/wp-admin/plugins.php

    and when I click the 'options' link, I wind up at

    http://domain.com/blogs/site-ONE/wp-admin/?c=1 <- note the appended querystring, too.

    The 'options' link points to a legit-looking URL: http://domain.com/blogs/site-TWO/wp-admin/admin.php?page=rvy-site_options

    OTHER THOUGHTS
    Maybe this wouldn't happen if the user was not the admin for multiple sites, but we can't count on that.

    http://wordpress.org/extend/plugins/revisionary/

  2. James Revillini
    Member
    Posted 3 years ago #

    MORE INFO
    I have the plugin 'Capabilty Manager' installed and by going to Users > Capabilities, I can see the Revisor role, so this plugin is only partially broken.

    I have successfully copied the Revisor role to another role using capability manager, assigned the new role to a user, logged in as that user, and confirmed that the Revisionary functionality is there and working. What is not working is the integration with the admin menu. I did not receive an e-mail notification when a post was revised, but I assume there are some settings that must be set for that to work.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic