WordPress.org

Ready to get started?Download WordPress

Forums

Resume Submissions & Job Postings
[Plugin: Resumé Submissions & Job Postings] TinyMCE no line breaks (20 posts)

  1. 3ring
    Member
    Posted 2 years ago #

    While creating a job post, when in Visual mode the TinyMCE editor is not creating line breaks/paragraphs where indicated. It seems where <p> tags should be they are getting stripped out when publishing the job post, as they are not visible when viewing the live post.

    http://wordpress.org/extend/plugins/resume-submissions-job-postings/

  2. kandrews
    Member
    Plugin Author

    Posted 2 years ago #

    I responded to this in the ticket you submitted in our ticket system.

    Thanks.

    (Will post resolution here for those with the same bug)

  3. metkha
    Member
    Posted 2 years ago #

    Yeah, I'm having the same problem as well.

  4. kandrews
    Member
    Plugin Author

    Posted 2 years ago #

    Which version are you running?

  5. metkha
    Member
    Posted 2 years ago #

    I'm running V2.1.5

  6. kandrews
    Member
    Plugin Author

    Posted 2 years ago #

    Ok, I looked at my code and I have wpautop set to true for the wp_editor() settings, so it may be a bug with WordPress itself.

    I will try to look into it some more, but in the meantime, I have TinyMCE Advanced installed which has an option in the settings to add p tags and breaks.

  7. donfre
    Member
    Posted 2 years ago #

    Have the same issue, know its not the perfect solution, but i went into the html view and just added < br > to all the places. A minor problem to a great plugin - kudos to developer.

  8. kandrews
    Member
    Plugin Author

    Posted 2 years ago #

    Yeah, I will have to research as to why this is happening.

    But thanks for using the plugin!

  9. kandrews
    Member
    Plugin Author

    Posted 2 years ago #

    Hey guys,

    Could you do a test for me?

    In the includes folder of the plugin, find the file functions.php.

    Find the function "setTinySetting".
    In that function find the line,
    'wpautop' => true,
    and change it to ,
    'wpautop' => false,

    Save, then see if the tinymce is adding the breaks now.

    Thanks.

  10. BMurchison
    Member
    Posted 2 years ago #

    I'm having the same issue. Any time I add a line break or any tag of any kind it gets removed. Both with HTML view and Visual. TinyMCE Advanced doesn't seem to work either.

    Tried everything mentioned here, including what kandrews said, no luck.

  11. kandrews
    Member
    Plugin Author

    Posted 2 years ago #

    Which version are you running of WordPress and the plugin?

  12. BMurchison
    Member
    Posted 2 years ago #

    Sorry, I'm using:

    Resumé Submissions & Job Postings: Version 2.1.8
    WordPress: Version 3.3.2

  13. kandrews
    Member
    Plugin Author

    Posted 2 years ago #

    Ok,

    Could you actually go through the steps above, but instead of having: 'wpautop' => false,
    change it to:
    'wpautop' => true,

    I don't know why this has been a problem, unless it is the editor itself.

  14. wendizblog
    Member
    Posted 2 years ago #

    I'm running into the same thing. I love this plugin and want to present it to a client in the next few weeks, but I don't think they will like the loss of formatting. I noticed I am also losing bullet points, but not bold.
    Resumé Submissions & Job Postings: Version 2.1.8
    WordPress: Version 3.3.2

  15. wendizblog
    Member
    Posted 2 years ago #

    I'm running into the same thing. I love this plugin and want to present it to a client in the next few weeks, but I don't think they will like the loss of formatting. I noticed I am also losing bullet points, but not bold.
    Resumé Submissions & Job Postings: Version 2.1.8
    WordPress: Version 3.3.2

  16. wendizblog
    Member
    Posted 2 years ago #

    sorry for the double post...
    anyway, wanted to mention that I've also tried your suggestion. Mine was set to false, changed it to true.

  17. kandrews
    Member
    Plugin Author

    Posted 2 years ago #

    Ok, if it is just keeping the bold, then the function I have wrapped around to sanitize the input needs to be changed. I am working on an update now which should clear up some bugs.

  18. Skaos
    Member
    Posted 2 years ago #

    Hey Andrews,

    As many already said, the job postings page still is showing no breaking lines. Do you maybe have a clue where the problem might be? Also listings do not work, unsorted and sorted.

    Also tried your possible solution with wpautop, but it did not help.

    I really like your plugin and it works good. But this issue is a major problem, because the visual appearance of job postings is important to my employer and also to myself ;-)

  19. kandrews
    Member
    Plugin Author

    Posted 2 years ago #

    With the line breaks, do you have another plugin installed that configures WordPress' TinyMCE, like TinyMCE Advanced? I have noticed that the wpeditor() gets out of whack if something is modifying it.

    In the next update, there will be an option to set the editor to true or false seeing as it works both ways based on the user.

    But the styling on the job postings will be fixed anyway since I am changing it to use custom post types.

  20. kandrews
    Member
    Plugin Author

    Posted 2 years ago #

    After looking into this more thoroughly, it seems that I cannot find a solution for the p and br tags. On my development site which is a fresh install along with this plugin, even my default WordPress posts and pages editor are throwing out the tags.

    So the only solution I can offer right now is to download an advanced editor like TinyMCE Advanced.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic