WordPress.org

Ready to get started?Download WordPress

Forums

Responsive Slider
How to set the number of images? (11 posts)

  1. Airone
    Member
    Posted 2 years ago #

    Hi! Everything works fine but... I loaded 10 images and it only shows the last 3 uploaded! Strange, I know... is there some setting I can check?
    Thank you very much and please go on developing the plug-in, it's simple but effective!

    http://wordpress.org/extend/plugins/responsive-slider/

  2. Jandal
    Member
    Posted 2 years ago #

    Hello Airone,

    I just had the same question and was looking in the code to find where and how this was set.

    Easy Answer, and possibly an annoyance for some people, it is set in

    Settings > Reading > Blog pages to show at most

    Set the number of "posts" here to the maximum number of slides you would like to see.

    Awesome plugin!
    Thank you,
    =-)

  3. Airone
    Member
    Posted 1 year ago #

    Hey Jandal,
    much thanx!

    It works, but it isn't really the best solution. This should be in the plugin's settings only!

    Maybe next realease?!?
    Peace.

  4. alexandruv
    Member
    Posted 1 year ago #

    OMG!

    It drove me nuts - was looking for this.
    However this is not OK, it should be a plugin setting!

    Thanks Jandal!

  5. Lane Lester
    Member
    Posted 1 year ago #

    Once again I regret not being a PHP expert.

    It seems a workaround would be to save the maximum_pages value, redefine it to some higher number, and then restore it at the end of the plugin.

    I did a google, and it looks like the value is: posts_per_page

    I gave it a shot, but it didn't work. At the top of responsive-slider.php, I put:

    $temppp = $posts_per_page;
    $posts_per_page = 10;

    and at the bottom I put:
    $posts_per_page = $temppp;

    But I still got only two slides, the setting in Reading.

  6. Ajay Patel
    Member
    Posted 1 year ago #

    Thanks Jandal, Thanks to author for great plugin.

  7. changkhongayngo
    Member
    Posted 1 year ago #

    i using travel blue theme!
    i tried set number post more but it only show 5 images?
    how to?
    regard!

  8. Griden
    Member
    Plugin Author

    Posted 1 year ago #

    The plugin now ignores that setting and should display all slides. Simply update it if you are using an older version.

  9. cannondale63
    Member
    Posted 1 year ago #

    No, sorry, I've installed the newest version (0.1.8), but the slider shows only as much pictures as I have set here: Settings > Reading > Blog pages to show at most.

    Thats curious. Could anybody help me?

    My blogs URL: http://www.velofahrer.ch

    Thanks, Dominik

  10. Griden
    Member
    Plugin Author

    Posted 1 year ago #

    Something (the theme or a plugin) might be modifying the main query. It's just a guess, but you can try disabling plugins and/or switching to another theme to see if this is the case.

  11. danielnichols
    Member
    Posted 1 year ago #

    I use the responsive theme and am limited to '3' slides.

    Could this be amended somehow please!

    Thanks!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic