WordPress.org

Ready to get started?Download WordPress

Forums

RePress
Permalink/htaccess problem? (2 posts)

  1. loades
    Member
    Posted 1 year ago #

    The installations say to "Make sure you have permalinks enabled in your WordPress configuration ( this should result in a .htaccess file with the proper Mod Rewrite rules! ).

    I assume permalinks are enabled on my installation because under 'Permalink Settings' 'Default' is selected. Is this enough or is there something else to do?

    I ask because RePress isn't working in that it gives a page not found error. I've opened the .htaccess file and can find no reference to repress in it. What have I misssed?

    http://wordpress.org/extend/plugins/repress/

  2. emile_all4xs
    Member
    Plugin Author

    Posted 1 year ago #

    Hi loades,

    You should change your permalink settings to something like 'post-name' in other for WordPress to automatically enable permalinks.

    Please note: your blog page urls wil now have the title of posts and pages in the url. Most people things this is nicer, but you might not want it.

    You can manually edit the .htaccess too. Then you don't need to change permalink settings. Make sure the following code block is inside your .htaccess file:

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    Hope this helps and good luck!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.