WordPress.org

Ready to get started?Download WordPress

Forums

Repost
[resolved] Content not syncing between wordpress site and repost.us (7 posts)

  1. sledge81
    Member
    Posted 3 years ago #

    Hi.. there seems to be some conflict when this plugin is used and the site configured on repost.us Despite installing and activating the plugin there is always the error when the button on a post is clicked about a syndication error

    http://wordpress.org/extend/plugins/repostus/

  2. xmasons
    Member
    Plugin Author

    Posted 3 years ago #

    Howdy, sledge81!

    I'm the author of the Repost.Us plugin, so I should be able to assist you with your issue. I'll need a bit more information about what you are experiencing. Have you signed up for an account on http://www.repost.us/ and set up your site through our host tool?

    flint

  3. sledge81
    Member
    Posted 3 years ago #

    Hi, thanks for replying.

    Yep, I created an account repost.us and got the API key which I fed into the plugin.

    The button displays fine in the post page and when I click on the button I get this message: Error: 'This page is not found in our system

    In the repost.us 'Summary and status of sites' my site shows incomplete because repost.us installation is not installed.

    Do I need to use the javascript and insert into the <head> section of my site? I mean is this a required thing to do because just above the code you state that users can make use of the WP plugin.

  4. xmasons
    Member
    Plugin Author

    Posted 3 years ago #

    Using the Repost.Us WordPress plugin automatically installs the necessary javascript and meta tag. They are necessary to make your site enabled to use the service, and you don't need to manually do this yourself.

    Could you provide a link of your site so I may figure out the issue?

    Thanks!

    flint

  5. sledge81
    Member
    Posted 3 years ago #

    http://www.forexpromos.com

    Click on any article and at the bottom of the post I have the repost.us button

    Let me know!

  6. xmasons
    Member
    Plugin Author

    Posted 3 years ago #

    Thanks for catching this minor bug, although it does greatly impact your site. Here's the fix (on an example page):

    Where you have:
    <div class='rpuRepostUsButton'><a href='https://secure.repost.us/syndicate/create?url=http://www.forexpromos.com/daily-market-review-may-11th'>

    Replace with:
    <div><a class='rpuRepostUsButton' href='https://secure.repost.us/syndicate/create?url=http://www.forexpromos.com/daily-market-review-may-11th'>

    You'll notice that the class rpuRepostUsButton was originally located in the DIV. By moving it into the A tag, this should remedy the issue.

    Let me know how this works out for you.

    flint

  7. xmasons
    Member
    Plugin Author

    Posted 3 years ago #

    Additionally, it appears that you may have a plugin or service on your site to stop other sites from image scrapping. This will most likely create a 404 error when folks republish your content. The fix for that is to whitelist the sites: *.repost.us and static.1.rp-api.com so that they can link the images.

    If you have any further questions in regards to this, please let me know.

    flint

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags