WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: @Reply \w comment preview] jQuery requried? (4 posts)

  1. igitur
    Member
    Posted 5 years ago #

    It seems jQuery is required for this plugin to work? I couldn't find it in the installation package and it's not mention anywhere on the plugin's site.

    I already use Prototype so I don't really want to include another JS library. Is it really necessary to depend on jQuery for such a seemingly simple task?

    http://wordpress.org/extend/plugins/reply-w-comment-preview/

  2. Marcu5
    Member
    Posted 5 years ago #

    you're rigth.

    i fixed loading jQuery in version 0.0.4 (if only i could find out when jQuery was added to WP... bummer) - and also added a copy of jquery for backwards compatibility

    this IS an early version of the plugin, maybe i will make it work with other js-libs as well in the future...

  3. igitur
    Member
    Posted 5 years ago #

    Thanks.

    I'd prefer no dependency on any JS library. They add a lot of download overhead.

    This plugin should be possible by using straight DOM functions... right?

  4. Marcu5
    Member
    Posted 5 years ago #

    personally i find that 31kB overhead quite bearable given the joy jQuery brings coding-whise. also chances are good that jQuery gets loaded by other plugins anyways (of course not all of those use WP's built in loading mechanism which would greatly reduce redundancies).

Topic Closed

This topic has been closed to new replies.

About this Topic