WordPress.org

Ready to get started?Download WordPress

Forums

Relevanssi - A Better Search
[Plugin: Relevanssi] If you Timeout on Indexing (4 posts)

  1. Sevenhelmets
    Member
    Posted 4 years ago #

    Hi there

    Just a warning to other users, attempting to build a large index (ie thousands of posts) with Relevanssi will not work on a shared server, as you will most likely get a timeout:

    Fatal error: Maximum execution time of 30 seconds exceeded in ...

    The solution is not applicable if you are on a shared server, as you will not be given priviledges to alter the file, but if you can, you need to access the php.ini file (normally on root), find the line:

    max_execution_time

    and change that to something higher than 30 seconds (ie 90).

    Just thought I'd put that out there, seeing as I had this problem and couldn't figure it out for a while....

    PS. This is not an issue with the plugin itself, but with your server setup and Apache.

    http://wordpress.org/extend/plugins/relevanssi/

  2. Mikko Saari
    Member
    Plugin Author

    Posted 4 years ago #

    That's why there's the continue indexing button - if the indexing doesn't go through, just click continue indexing and it'll continue where it left.

    If PHP is not running in safe mode, there's also the set_time_limit() function which can be set in the script, without access to php.ini.

  3. cjbmeb14
    Member
    Posted 4 years ago #

    Mine is a different problem.
    I have installed Relevanssi but after building the index it comes back saying: Fatal error: Maximum execution time of 8 seconds exceeded

    As far as I can see it is something I have to change in the php.ini file but where is the php.ini file.

    Or is this another problem.

  4. Mikko Saari
    Member
    Plugin Author

    Posted 4 years ago #

    8 seconds is very strict max execution time. If you don't operate your own host, you probably won't have access to php.ini. Try the set_time_limit() function, but I'm not sure if that'll work either.

    Sounds like a change of hosting might be the best option...

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags