WordPress.org

Ready to get started?Download WordPress

Forums

Relevanssi - A Better Search
[resolved] Search index empty after upgrade (10 posts)

  1. Alex997
    Member
    Posted 1 year ago #

    Hello

    Today I upgraded to version 3.0 of Relevanssi on my Accountants in London WordPress website, however after I did all the index was emptied and it wont come back with a rebuild. I get no search results on the site with any keyword.

    In the admin console it just says:

    State of the Index

    • Documents in the index: 0
    • Terms in the index: 0
    • Highest post ID indexed:

    Please could you help fix this issue?

    Best regards,

    Alex

    http://wordpress.org/extend/plugins/relevanssi/

  2. Alex997
    Member
    Posted 1 year ago #

    OK I got it working.

    For others who have the same issue, you just have to:

    1) Plugins > Installed Plugins > deactivate the plugin

    2) (clear caches if running something like W3 Total Cache)

    3) Reactivate the plugin

    4) (clear caches if running something like W3 Total Cache)

    5) Go to the Relevanssi plugin settings page and rebuild the index

  3. Mikko Saari
    Member
    Plugin Author

    Posted 1 year ago #

    Yes. The problem is caused by the database structure, which has changed between versions. When the plugin is activated, it should update the database. However, for some reason I don't quite understand, WP plugin upgrade process does not trigger the activation hook. That doesn't make much sense to me.

  4. Gsk8
    Member
    Posted 1 year ago #

    I upgraded but my search results have disappeared. I have no "cache" to clear and can't figure out what to do? I've even changed the number of documents from 500 to 25 with the same result below after building the index.

    State of the Index

    Documents in the index: 0
    Terms in the index: 0
    Highest post ID indexed:

  5. robanna
    Member
    Posted 1 year ago #

    I'm having the same trouble. I even unistalled/reistalled the plugin but the indexing results in zero docs indexed.

  6. Mikko Saari
    Member
    Plugin Author

    Posted 1 year ago #

    Robanna, you said in the other thread you're on multi-site. You need Premium for multi-site to work.

    Gsk8, have you tried deactivating the plugin and activating it again? If that doesn't help, try deleting the plugin and reinstalling it.

  7. Gsk8
    Member
    Posted 1 year ago #

    Figured it out. For some reason no post types were selected for indexing. See "Indexing options". I just checked "post" and "page" and started indexing, and everything seems to work.

    Thanks!

  8. robanna
    Member
    Posted 1 year ago #

    I think the same thing happened to me. After deactivating/activating, the Indexing Options were all unchecked.

  9. andykrier
    Member
    Posted 1 year ago #

    After upgrading to 3.0 I am not getting any search results. I've emptied all caches (W3TC and Relevanssi) . I have deactivated and reactivated, clearing caches in between each step. I have also rebuilt the index (a few times).

    State of the Index

    Documents in the index: 262
    Terms in the index: 9712
    Highest post ID indexed: 2198

    Today, I upgraded to 3.0.1 hoping that this issue had been resolved, but still no luck. Any suggestions would be highly appreciated? Thanks.

  10. Mikko Saari
    Member
    Plugin Author

    Posted 1 year ago #

    If you can rebuild the index, then the database and the settings are correct.

    Without more specific details, it's really hard to say what's the problem. Could be many things, and figuring out what it is requires a closer look under the hood - where the search process fails? Relevanssi probably gets some results, but they disappear at some point. Where?

    If nothing else helps, you can still download 2.9.14 from WordPress.org repository.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags